1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Installing Civ 4 on Windows 7/Vista (32-/64-bit)

Discussion in 'Civ4 - Technical Support' started by kiwitt, Jan 19, 2011.

  1. kiwitt

    kiwitt Road to War Modder

    Joined:
    Jan 11, 2006
    Messages:
    5,548
    Location:
    Auckland, NZ (GMT+12)
    Contact Amazon?
     
  2. cseanny

    cseanny Emperor

    Joined:
    Apr 3, 2008
    Messages:
    1,191
    I just bought the same thing from Amazon a few days ago (and I use Windows 7). Just follow this and you should have no problems: http://forums.civfanatics.com/showthread.php?p=14173585#post14173585
     
  3. SuleimanIV

    SuleimanIV Chieftain

    Joined:
    Mar 13, 2016
    Messages:
    1
    HI,

    I have two computers, one runs on Windows 7 and the other on 8.1

    I am sorry to say that in my case KWİT's advice did not work and even if did, it's taking too lond to download all these files, and all this work is simply unnecessary. Please check the discussion in "login with administrator privilege" in this forum instead.

    Here Calibar says:

    So check the link above if you are not sure.

    All you need to do, in both opretaing systems is:

    Then restart the computer. Then install the game (if it is not already installed) And thats it!

    - I don't know why all these patch files were given. even if you want to install them you have to go through these steps first.

    :)
     
  4. kiwitt

    kiwitt Road to War Modder

    Joined:
    Jan 11, 2006
    Messages:
    5,548
    Location:
    Auckland, NZ (GMT+12)
    RE: Patch files. If you play Civ IV Vanilla and Warlords you will need them. In addition, BTS also uses files from these versions often.
     
  5. Civ Vicious

    Civ Vicious Chieftain

    Joined:
    Feb 4, 2011
    Messages:
    30
    I downloaded the 3.19 patch from the main link at GameWatcher and the file is corrupt.

    The download at GamersHell worked for me.
     
  6. Cor'e =)

    Cor'e =) Warlord

    Joined:
    Feb 27, 2009
    Messages:
    229
    Please add this to 1st post in full or modified (or as you like):

    Civilization 4 Complete has only two Setup.exe files, one for all 4 Civs and one for just Colonization itself.

    Civ 4 Complete has these patch levels already:
    Civ Van 174/Save 103/Build 1.7.4.0
    Civ War 213/Save 200/Build 2.1.3.0
    Civ BtS 317/Save 301/Build 3.1.3.1 (104717)
    Civ Col 100/Save 1/Build 1.0.0.0 (109295)

    After BtS Patch 319:
    Spoiler :
    SHA-256:
    Code:
    E477D30BBAF75824951BFC80556F50621F53107CC8A6061FAC9D2B8E9AE9696F
    Civ BtS 319/Save 302/Build 3.1.9.0 (128100)

    On WinPro x64:
    To uninstall right-click on the Setup.exe and Run as Administrator, do not choose express unless you want it all uninstalled (Saves, Setting, Maps, etc.).

    For a cleaner complete uninstall, you will want to check that all Civ4 binaries & patches were uninstalled in the MS Control Panel>Programs & Features as well, if any then uninstall them. If any Civ4 game folders have stuff you may also delete them, this may delete more than you want, such as mods & configs, so be warned.

    To install Right-click on the Setup.exe and Run as Administrator (if it is was never installed or has been uninstalled, otherwise it will uninstall!).

    Choose Custom install, choose Install for All Users (THIS WILL CENTRALIZE ALL THE GAME & CONFIG FILES WHERE EVERYONE USES THEM) or uncheck Install for All Users (THIS WILL CENTRALIZE ONLY PART OF THE GAME FILES, NOT THE SAVES & CONFIG FILES ETC.). I do not think Registration still works, so leave it unchecked. Choose your Destination Location. Click Install and wait a long time as for the main game.

    When all installation windows close - WAIT! Next it will try to uninstall/install Colonization, if uninstalling you'll have the same check boxes if you did not choose Express, then go to the steps for a manual re-install below. But if installing, just follow prompts as before for the main game.

    If only installing or re-installing Colonization, then go into the Colonization folder and right-click on that Setup.exe and Run as Administrator (do not choose express unless you want it all uninstalled - Saves, Setting, Maps, etc.). Choose your Destination Location. Click Install and wait a not so long time.

    About Game Shortcuts: When you choose to install for all users you will not have desktop icons (thanks!), but you will have the Start>All Programs shortcuts in this (Win7) folder: C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Games, so move them where you want them.

    About Mouse: Your mouse driver may not work completely on game start, you can use the keyboard to navigate or exit, use Escape, Arrows, and Tab. For example i use a gamepad as a mouse, and my mouse pointer is invisible, this may be just because of my various mouse driver(s) or you may want to disable mouse pointer trails for example.

    BtS Crash: If you get an AppCrash like this below, then re-install the BtS 319 patch (right-click and Run as Administrator!).
     

    Attached Files:

  7. fed1943

    fed1943 Emperor

    Joined:
    Nov 28, 2005
    Messages:
    1,185
    Location:
    Lisbon
    Windows 7 Ultimate; Civ4 Complete; patch 3.19. Always run as Adm.
    It works!
    But it says my computer not good enough and performs worse graphics.
    Very strange because is the same machine I played years with. (it was a re-install).
    Can someone help me, please.
    My thanks in advance.
     
  8. rysmiel

    rysmiel Emperor

    Joined:
    Oct 23, 2007
    Messages:
    1,401
    Thank you, this has been extremely useful.
     
  9. ponderingnugget

    ponderingnugget Chieftain

    Joined:
    Apr 11, 2017
    Messages:
    1
    Question: I had been playing civ iv warlords successfully on my windows 7 system until I installed certain updates about 6 months ago. Now none of my civ iv titles will launch. I want to try these patches, and am wondering if it's possible to install them without reinstalling civ? Can I move my civ files from c\program\files to a new games folder and then patch? If not, I need to find the folder with my saved games and save them to a new location because I have several that I don't want to lose. Any suggestions? Thank you in advance.
     
  10. buck beach

    buck beach Prince

    Joined:
    Dec 2, 2001
    Messages:
    433
    I ran into the same issue only my game graphics slowed down to a crawl. In my efforts to get the game up and running I deleted some USB drivers (I had read they would automatically reinstall when I started the computer. WRONG !!!) Took several days to get the computer running right but still had the problem. Somehow DirectX 9 was eliminate with the updates you mentioned. Tried to install it but my feeble mind was unable to figure it out. My BTS sword disc wouldn't load and I ended up Irepurchasing the game from Steam. Game runs fine now but my saves are not recognized.

    Hope this helps in some way.

    Buck.
     
  11. s.bernbaum

    s.bernbaum Mostly lurking

    Joined:
    Dec 2, 2006
    Messages:
    2,707
    Location:
    The wilds of Montana
    Microsoft released a patch in September that, among other things, prevents discs using the copy protection scheme that CIV uses from being accessed. Have a look at the thread in this forum titled "Please login with administrator privileges and try again" for an explanation, discussion, and a few work arounds to allow you to once again access your discs. This may be the problem, since it prevents disc based games, such as all versions of disc based CIV from launching.
     
  12. jimmywfl

    jimmywfl Chieftain

    Joined:
    Oct 10, 2009
    Messages:
    46
    Location:
    Vienna, Austria
    I have downloaded that patch via this forum and Gamewatcher, but that file is corrupt and will not decompress.
     
  13. Ramkhamhaeng

    Ramkhamhaeng Warlord

    Joined:
    Feb 24, 2014
    Messages:
    146

Share This Page