Irritating thing about Shift-P moves

Karlsen

Chieftain
Joined
Apr 20, 2001
Messages
46
Location
Australia
No not the fact that no enough workers are sent to clean up the pollution (which is a bug that should be fixed).

I found in the current game (Huge map, Lots of units on the map) that when selecting Shift-P to get a worker to clean up some pollution automatically that the worker actually moves 5 squares the map moves, the worker moves 5 squares the map moves etc. etc. This can take a very long time if a worker is moving from one side of the continent to the other. The normal goto, click and hold on the target square doesn't work like this, you don't see the map continually readjusting as the worker hops five squares closer to his target each map move. On the goto, the unit just arrives (after a delay). The 5 squares, readjust method is considerably slower than other ways the computer moves units. Why is this so? And more importantly can it be fixed.

It may seem a minor thing. but if you have 10 or so spots of pollution and you are waiting 10-20 seconds for each worker to arrive at his/her destination then it all makes for a slow turn.

I had all animation except for manual moves turned off from memory.
 

PaulNAdhe

Warlord
Joined
Nov 8, 2001
Messages
221
It's probably because Shift P tells the worker to clean up pollution anywhere. And it's moving forward looking for pollution finding none it moves 5 more squares. I've never noticed this as being a big problem. I've had units on pollution control move into an AI civ's territory to clean up pollution. Of course I had RoP with that civ.

I put all my workers on Auto and they go sit in a city until they're needed. For pollution control, to rebuild improvements the evil Egyptians have destroyed, build improvements in newly expanded cultural border areas, etc.

The Automate worker function in Civ III is such an improvement over Civ II that I don't even think about them anymore.
 

loki

Warlord
Joined
Nov 19, 2001
Messages
145
Location
Paris, France
I noticed it too (on railroads). I think it's a post patch bug, because I didn't remember this behaviour in 1.07

loki
 

Woody

General
Joined
Nov 16, 2001
Messages
439
go to prefs and turn off show my automatic moves
 

Karlsen

Chieftain
Joined
Apr 20, 2001
Messages
46
Location
Australia
Turning off my automatic moves does stop the stupid 5 square jumping, although it does mean you sit looking at a frozen screen until your worker arrives at the mystery destination (i.e. because you are not showing the move you don't actually see where the worker ended up)
 
Top Bottom