1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  3. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  4. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  5. Dismiss Notice
  6. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

Latest ATI Drivers

Discussion in 'Civ4 - Technical Support' started by ainwood, Oct 26, 2005.

  1. ainwood

    ainwood Consultant. Administrator

    Joined:
    Oct 5, 2001
    Messages:
    30,009
    With thanks to Moose @ Firaxis.

    Here are the latest ATI drivers:

    # Radeon® display driver 8.18
    # Catalyst™ Control Center version 5.10

    LAPTOP:
    Laptop drivers
    DESKTOP:
    Desktop Drivers.

    1. ATI recommends Windows XP Service Pack 2 or higher to be installed.
    2. You must have Microsoft .NET Framework installed prior to downloading and installing the CATALYST Control Center
    3. The Catalyst Uninstaller is an optional download. We recommend using this utility to uninstall any previously installed Catalyst drivers prior to installation.

    BTW - you can get the .Net framework here if you don't have it already.
     
  2. picklion

    picklion Chieftain

    Joined:
    Oct 26, 2005
    Messages:
    8
    I can't see where the 8.18 drivers are on those sites and the catalyst thing keeps telling me it can't be installed on my system(with no reason why). If you or anyone else has any info on where to get some ATI drivers please tell me.
     
  3. Speaker

    Speaker Chieftain

    Joined:
    Nov 4, 2002
    Messages:
    2,097
    Location:
    Section 1
    File=6.14
    Driver=8.18
    Catalyst=5.10
    They are the same thing.

    If you try to download file 8.18 from ATI's site, it won't work because it is a Linux file.
     
  4. picklion

    picklion Chieftain

    Joined:
    Oct 26, 2005
    Messages:
    8
    Ok that clears up my problem because I have file version 6.14.00...etc
    but the graphics thing is still there. I suppose we're all going to have to wait until we get a response from the creators on this issue.
     
  5. Speaker

    Speaker Chieftain

    Joined:
    Nov 4, 2002
    Messages:
    2,097
    Location:
    Section 1
    They are working hard on it.
     
  6. stich0602

    stich0602 Chieftain

    Joined:
    Oct 26, 2005
    Messages:
    8
    sry.. 2 different driver types here... you can delete this
     
  7. Iskan

    Iskan Chieftain

    Joined:
    Nov 5, 2001
    Messages:
    14
    Location:
    DC
    "Lost" is coming up. Good show. And TV doesn't give any rendering error messages.
    But... :mad: I'd rather play Civ and tape the show. Darn. it is frustrating. Civ has been my favorite game since the beginning.
     
  8. Iskan

    Iskan Chieftain

    Joined:
    Nov 5, 2001
    Messages:
    14
    Location:
    DC
    Oo-oo-oo! One frustration after another. Today's "Lost" is a repeat. Goodness gracious.
     
  9. clipset

    clipset Chieftain

    Joined:
    Jul 29, 2005
    Messages:
    8
    links don't work for ati
     
  10. snowg00n

    snowg00n Chieftain

    Joined:
    Oct 26, 2005
    Messages:
    8
    Yeah, this did nothing, running with ati mobility radeon x600 and couldn't install catalyst 5.10...because?
     
  11. iamhurtin

    iamhurtin Chieftain

    Joined:
    Oct 27, 2005
    Messages:
    1
    try the beta cats that are out
    see if that fixes ur prob
     
  12. TNRandy

    TNRandy Chieftain

    Joined:
    Oct 25, 2005
    Messages:
    7
    Location:
    Nashville, TN
    The following ATI graphics driver will work for the Sony VIAO PCG-GRV680 laptop computer and can be found on the Sony website:

    ATI Radeon Mobility 9000

    Driver Date: 7/30/2003

    Driver Version: 6.14.10.6382
     
  13. s3d

    s3d Chieftain

    Joined:
    Dec 27, 2001
    Messages:
    236
  14. snowg00n

    snowg00n Chieftain

    Joined:
    Oct 26, 2005
    Messages:
    8
    s3d - thank you. i'm running on a mobility radeon x600, and following your link, http://ati.com/online/mobilecatalyst/, got me the update i needed. everything in the game looks beautiful, especially on 1440 x 900. now, only 2 hours till i can leave the office and play.

    this forum saved my life.
     
  15. shadahi

    shadahi Chieftain

    Joined:
    Oct 15, 2005
    Messages:
    21
    Location:
    Brewer, Maine
    this is the version I am running:

    Driver Packaging Version 8.18-050914a1-027256C-ATI
    CATALYST™ Version 05.10
    Provider ATI Technologies Inc.
    2D Driver Version 6.14.10.6575
    2D Driver File Path System\CurrentControlSet\Control\Video\{8B6BD26F-52A3-4810-9B7A-5CD580CD19FC}\0000
    Direct3D Version 6.14.10.0347
    OpenGL Version 6.14.10.5396
    CATALYST™ Control Center Version 1.2.2084.76
    AIW/VIVO WDM Driver Version 6.14.10.6238
    AIW/VIVO WDM SP Driver Version 6.14.10.6238

    I'm pretty sure it the latest driver pack.

    I uninstalled my old drivers (reboot) installed 5.10 (reboot) installed civ IV with the dx on the disk (reboot)

    nada

    radeon 5550 se
    (I meet ALL the min reqs and then some)
     
  16. Al Fredo

    Al Fredo Chieftain

    Joined:
    Jan 11, 2002
    Messages:
    70
  17. s3d

    s3d Chieftain

    Joined:
    Dec 27, 2001
    Messages:
    236
    Hmm, on my computer it's installed without problem.
    Have you got the file 5-10-mobile_xp_dd_ccc_enu_26777.exe ?
    THen you run it it's unpuck itself into
    C:\ATI\SUPPORT\5-10-mobile_xp_dd_ccc_enu_26777\
    and the only inf file is ee is
    C:\ATI\SUPPORT\5-10-mobile_xp_dd_ccc_enu_26777\Driver\XP_INF\CX_26777.inf

    Check your unpucked directory - is this file present ?
    If it's not you have a problem while unpucking file, or may be file was not completly downloaded.
    Also - this driver only for laptops, not desktops.
    It alsoo seems from inf file that only card starting from 9500 or better supported , but I may be wrong here :
    "ATI MOBILITY FIRE GL T2/T2e" = ati2mtag_M10GL, PCI\VEN_1002&DEV_4E54
    "ATI MOBILITY FireGL V3100" = ati2mtag_M22GL, PCI\VEN_1002&DEV_5464
    "ATI MOBILITY FireGL V3200" = ati2mtag_M24GL, PCI\VEN_1002&DEV_3154
    "ATI MOBILITY FireGL V5000" = ati2mtag_M26GL, PCI\VEN_1002&DEV_564B
    "ATI MOBILITY RADEON 9500" = ati2mtag_M10, PCI\VEN_1002&DEV_4E52
    "ATI MOBILITY RADEON 9550" = ati2mtag_M12, PCI\VEN_1002&DEV_4E56
    "ATI MOBILITY RADEON 9600/9700 Series" = ati2mtag_M10, PCI\VEN_1002&DEV_4E50
    "ATI MOBILITY RADEON 9800" = ati2mtag_M18, PCI\VEN_1002&DEV_4A4E
    "ATI MOBILITY RADEON X300" = ati2mtag_M22, PCI\VEN_1002&DEV_5460
    "ATI MOBILITY RADEON X300 " = ati2mtag_M24, PCI\VEN_1002&DEV_3152
    "ATI MOBILITY RADEON X600" = ati2mtag_M24, PCI\VEN_1002&DEV_3150
    "ATI MOBILITY RADEON X600 SE" = ati2mtag_M24C, PCI\VEN_1002&DEV_5462
    "ATI MOBILITY RADEON X700" = ati2mtag_M26, PCI\VEN_1002&DEV_5653
    "ATI MOBILITY RADEON X700 " = ati2mtag_M26, PCI\VEN_1002&DEV_5652
    "ATI MOBILITY RADEON X800" = ati2mtag_M28, PCI\VEN_1002&DEV_5D4A
    "ATI MOBILITY RADEON X800 XT" = ati2mtag_M28, PCI\VEN_1002&DEV_5D48
     
  18. Harre

    Harre Chieftain

    Joined:
    May 10, 2004
    Messages:
    38
    Location:
    Sweden
  19. alamo

    alamo bang!

    Joined:
    Nov 20, 2002
    Messages:
    1,569
    Location:
    Texas
    This is for older cards, according to the doc.

    It didn't do anyhting for me - Radeon 9550.
     
  20. Driek Desmet

    Driek Desmet Chieftain

    Joined:
    Mar 20, 2004
    Messages:
    13
    Location:
    Belgium
    Also get the same error after the patje ""INF error. Video driver not found."
    It's an Mobile Radeon 7500 inside an R51 IBM
     

Share This Page