1. Firaxis celebrates the "Asian American and Pacific Islander Heritage Month", and offers a give-away of a Civ6 anthology copy (5 in total)! For all the details, please check the thread here. .
    Dismiss Notice
  2. Old World has finally been released on GOG and Steam, besides also being available in the Epic store . Come to our Old World forum and discuss with us!
    Dismiss Notice

[NFP] (Linux) Game crashing since I bought New Frontier Pass, can't even get to the leader loading screen

Discussion in 'Civ6 - Technical Support' started by Raestloz, Jun 23, 2021.

  1. Raestloz

    Raestloz Chieftain

    Joined:
    Aug 12, 2015
    Messages:
    13
    So yeah, that's weird. I had Platinum Edition and it worked fine on my laptop, played quite a few turns on it, restarted multiple times, no problem

    After that I bought New Frontier Pass and as the title says, I can't play anymore. I can get into main menu just fine, tinker with options and whatnot, but attempting to play the game results in a crash after some loading

    I've tried verifying game integrity, deleting the config files, fully reinstalling the game, disabling everything except RnF and GS, nothing works. I'm completely baffled.

    What can I do now?

    As a side note, the launcher says "93% DLC installed" with Vietnam and Kublai Khan pack listed as "not installed" but in game under Additional Content -> Mods I can see them as available to be enabled. It persists through reinstall. I'm not sure how relevant that is, but at this point I'm pretty desperate
     

Share This Page