Mac Civ3 GOTM?

dojoboy

Tsalagi
Joined
Dec 30, 2001
Messages
4,280
Location
Tanasi, USA
Any mac users having trouble playing the GOTM? Everytime I try to play it a message says its "too big" to open. I don't understand.

Weeks ago, I asked if the GOTM was playable on Mac. The reply was that Civ2 GOTMs were so Civ3 GOTMs should be.

Please advise.
 

K-Man

Warlord
Joined
Jan 9, 2002
Messages
149
Location
Edmonton, Alberta, Canada
I was able to download it and play it just fine. I did not fare very well at all, but I had no trouble playing it, nor did it tell me it was too big to open. I don't know what the problem would be for you.
 

dojoboy

Tsalagi
Joined
Dec 30, 2001
Messages
4,280
Location
Tanasi, USA
Hey CofH, I tried again but no luck. The message is, "too large to open w/ simple text." I'm not that computer savy, but, perhaps I need a different application to open it.

The file looks like other PC files that I've downloaded in the past by accident. It looks like a document, not like a saved Civ game. What exactly am I downloading? A saved game or specs for a game?

Thanks for your help.
 

dojoboy

Tsalagi
Joined
Dec 30, 2001
Messages
4,280
Location
Tanasi, USA
Its unzipped automatically after download, by stuff it expander. Same issue exists with the unzipped version.
 

mickelsp

Chieftain
Joined
Jan 18, 2002
Messages
11
Location
Houston, TX
It sounds like your computer thinks the game file is a text file rather than a CivIII file.
There are two things that I would try.

1) The first is simply to open the game from inside of Civ III instead of double-clicking it from the Finder. This should work.

2) If it doesn't, then (assuming you're running in OS 9.x) whip out ResEdit (do so with caution!!!) and "Get info" from the "File" menu on a game file that works for you. Look at what the "Type" and "Creator" codes for this file are.
Then, "Get info" for the GOTM file. Make sure the "Type" and "Creator" codes are the same as in the other file.

What is happening here is that Macs assign meta-information to files (these are the type and creator codes) whereas PC's attach a file extension (.txt for example). When you get the GOTM that was made on a PC, there is no meta-information attached and so your Mac tries to open the file in SimpleText (as a default) when you double click on the file. Opening it from within Civ III should work because Civ III will recognize that it is the right kind of file and will even attach the type/creator codes for you when you save the game. However, if that doesn't work for whatever reason, then you can use ResEdit to change the codes manually.
 

dojoboy

Tsalagi
Joined
Dec 30, 2001
Messages
4,280
Location
Tanasi, USA
I tried placing it in the Civ3 folder and unzipped it, but I had the same results. When I click on the file to unzip it, a message reads, "the application used to create this "file" could not be found, please choose one of the below options." The only option provided is "stuff it expander."

My system is an 8.6, so no luck w/ ResEdit.

Is there a setting/preference somewhere for translating a file once it is downloaded?

Is there something I can download online that would help?

Whenever I download a patch (e.g. SMAC), I unzip it in the game folder and it works fine. I've even unzipped them on the desktop and copied it into the game folder with positive results.

I'm stumped.
 

mickelsp

Chieftain
Joined
Jan 18, 2002
Messages
11
Location
Houston, TX
What I meant by "open from inside the game" is that you should open CivIII with the application icon and then select "Load Game" from the CivIII menu. You ought to be able to locate the file that you want to open that way.

ResEdit works on pre-OS 9 systems; I just meant that it wouldn't work on OS X.
 
Top Bottom