1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

MODs compatible with Community Balance Patch (CBP)

Discussion in 'Community Patch Project' started by vyyt, Jan 29, 2015.

  1. darkstrat

    darkstrat Chieftain

    Joined:
    Jun 25, 2020
    Messages:
    47
    Gender:
    Male
    have you been able to solve the issue??
    or any updates, idc about the potential screen but the thief feature was sweet.
     
  2. black213

    black213 Emperor

    Joined:
    Mar 12, 2010
    Messages:
    1,548
    I don't know about how to fix it.
     
  3. skodkim

    skodkim Deity

    Joined:
    Jan 16, 2004
    Messages:
    2,313
    Location:
    Denmark
    It says that RtP should be compatible out of the box but I seem to be having problems.

    The top bar shows no Virtur/sovereignety yields if I dont use JFD's top bar mod and if I do the other stuff from CPP+WUI (e.g. happiness) don't show up/work.

    Any comments/help would be great!

    \Skodkim
     
  4. SLGray

    SLGray King

    Joined:
    May 18, 2015
    Messages:
    946
    Gender:
    Male
    Location:
    United Sates
    The list is not really up to date with the mods by JFD. JFD's mods really only need the Community Patch. He did give some support fro th complete Vox Populi.
     
    skodkim likes this.
  5. skodkim

    skodkim Deity

    Joined:
    Jan 16, 2004
    Messages:
    2,313
    Location:
    Denmark
    So it's possible to run his mods with the compete VP (which is my priority)? Could you point me to the support he gave? Haven't been able to find anything.

    \Skodkim
     
  6. SLGray

    SLGray King

    Joined:
    May 18, 2015
    Messages:
    946
    Gender:
    Male
    Location:
    United Sates
    What exactly are you wanting to use by JFD?
     
  7. skodkim

    skodkim Deity

    Joined:
    Jan 16, 2004
    Messages:
    2,313
    Location:
    Denmark
    Especially Epithets, sovereignty and cycles of power.

    Others like Ideological values and great philosophers sound fun too but they're second priority.

    Thing is there's so many related JFD mods and some of them, e.g. Top panel and tech tree mods, just say they're required for some of the others mods to work.

    \Skodkim
     
  8. SLGray

    SLGray King

    Joined:
    May 18, 2015
    Messages:
    946
    Gender:
    Male
    Location:
    United Sates
    If the mods change the same files as VP does then they will not be compatible.
     
  9. hawkseye17

    hawkseye17 Chieftain

    Joined:
    Jun 25, 2020
    Messages:
    36
    Gender:
    Male
    City-States Evolved is no longer compatible. The city-state builds settlers, but they just sit in the city and don't do anything.
     
  10. Balls of Steel Baby

    Balls of Steel Baby Chieftain

    Joined:
    Oct 4, 2016
    Messages:
    17
    Gender:
    Male
    "Culturally Linked Start Locations" does not work with "Rebalanced Resource Placement" option from Communitu_79 map script. Standard placement does work however.

    Not this mod
     
    Last edited: Jul 25, 2020
  11. Recursive

    Recursive Covets Lands That You Currently Own Moderator

    Joined:
    Dec 19, 2017
    Messages:
    2,373
    Gender:
    Male
    @hawkseye17 Compatibility should be re-added for next version, including in ilteroi's July 27 patch.
     
  12. Galaphile0125

    Galaphile0125 Duke

    Joined:
    Jan 14, 2015
    Messages:
    93
    Location:
    Cincinnati
    Has anyone been able to get the airbase tile improvement mod to work with VP? When I have it loaded I can't actually build it and on top of that every unit in the game no longer has an emblem so its hard to see where your units are outside of just playing in strategic view.
     
  13. Skidizzle

    Skidizzle Gameshow Host

    Joined:
    Sep 20, 2010
    Messages:
    108
    Looks like 8-16-2 breaks Really Advanced Setup, can anyone else confirm?
     
  14. hawkseye17

    hawkseye17 Chieftain

    Joined:
    Jun 25, 2020
    Messages:
    36
    Gender:
    Male
    In what way?
     
  15. Skidizzle

    Skidizzle Gameshow Host

    Joined:
    Sep 20, 2010
    Messages:
    108
    During game set up when I click the advanced setup button. It opens a blank window that I cannot back out of, so I’m stuck with the last settings I had before. I have to endtask and restart CIV.
     
  16. hawkseye17

    hawkseye17 Chieftain

    Joined:
    Jun 25, 2020
    Messages:
    36
    Gender:
    Male
    That's strange, it hasn't happened to me. It could be a mod conflict somewhere. Try going on the Github and doing a bug report
     
  17. JamesNinelives

    JamesNinelives Emperor

    Joined:
    Mar 16, 2019
    Messages:
    1,577
    Gender:
    Male
    Location:
    Australia
    I'm not experiencing this either, sorry. Might be a mod conflict with something else?
     
    vyyt likes this.
  18. donqrakko

    donqrakko Chieftain

    Joined:
    Oct 31, 2020
    Messages:
    5
    Gender:
    Male
    Hey, to make this all easy i've made a package of all future world files i've found for VOX 5.10.7 including yours. Also tweaked some variables in your xml and sql files to match latest VOX Populi version (techcostschanges, units, promotions)

    Description:

    Code:
    I'm not mod author of these files, just tweaked them a little bit and made a single pack of needed files to make this mod playable with VOX.
    
    Original file authors:
    
    TimurB - Future Perfection v3 
    https://forums.civfanatics.com/threads/future-perfection.626134/
    
    Nexmury - Future Worlds Compatibility fix 
    https://forums.civfanatics.com/threads/mods-compatible-with-community-balance-patch-cbp.542679/page-45#post-15797773
    
    What this do:
    
    Makes VOX 5.10.7 compatibile with Future Worlds. XML and SQL variables from original compatibility fix by Nexmury have been changed to match these from VOX 5.10.7 version (Techcosts, units promotions etc). 
    Everything what is needed except Future Worlds is included in this .zip file.
    I've tested it for a little while, everything seems to be working
    
    Installation:
    
    1. Install original Future Worlds from steam workshop or from civfanatics forum. 
    2. Extract Future Perfection (v 3).zip to your civilization 5 mod folder like my games/Sid Meier's Civilization 5/MODS
    3. Extract FW compatibility fix.zip to temporary folder
    4. Now repeat steps described by Nexmury in FW compatiblity fix/READ_ME.txt
    5. Play game, enable Future Worlds and Future Perfection and you are done!
    
     

    Attached Files:

    Nexmury likes this.
  19. MEQ

    MEQ Chieftain

    Joined:
    Nov 21, 2018
    Messages:
    22
    Gender:
    Female
    Location:
    Ireland
    Does anybody know how to turn off VPs inclusion of Faster Aircraft Animations? I actually like those original slow animations.
     
    vyyt likes this.
  20. Tekamthi

    Tekamthi Prince

    Joined:
    Aug 12, 2016
    Messages:
    492
    Look forward to trying this! Consider adding this to the thread here: https://forums.civfanatics.com/threads/future-world-compatibility.561717/
     

Share This Page