• Civilization 7 has been announced. For more info please check the forum here .

More WinXP woes!

martyep

Chieftain
Joined
Feb 23, 2002
Messages
5
I've had trouble with XP. I originally had the game on an older machine running Win98. Never had a problem with Civ II.
Now on my new machine, running XP, Civ II runs slower.
But WORSE -- I can't complete a victorious game! When the video comes up for my winning spaceship I get a cascade of error alert windows. These are titled "GET FRAME" with error message of "IC DecompressEx returned - 100." From here, I have to cold boot my machine. Ouch!
I downloaded Indeo ver 5.1...... but so what? Doesn't the program just use the old Indeo version from the CD anyway??
( I don't even know if Indeo has anything to do with this ).
I've re-installed twice with no change in results.
HELP!!
 
You must download and INSTALL the latest Indeo video drivers and codecs. The latest ones are found at www.ligos.com . All the versions of Civ 2 run fine on my copy of WinXP.
 
Thanks for the reply Cedric. I don't doubt the truth of what you say. But I'm missing the boat somewhere. I did the Indeo download and install, but the problem persists. Maybe it's my own methodology that needs debugging, but I'm stumped.
Just for the hell of it, I went to the folder of videos (on the CD), and tried to run each one using RealPlayer. Every video ran fine, except one -- the one titled "WINWIN". This must be the closing video that's causing me all this trouble. It's odd how everything works except this one video.
While I am fairly computer literate, I guess I wouldn't mind being Mickey Moused through this one if anyone has an idea about what I'm missing here.
Thanks again. Marty
 
Hmmm alright let's go through all of it.
Which version of Civ 2 do you have? Is it upgraded to the latest official version? Have you used Windows update to upgrade to the latest windows drivers and such? If you are using classic Civ 2 or Civ 2 FW you don't need the disk to play the game though you won't see any movies except the last one. If you have Civ 2 MGE then download the no-disk crack and see if it plays better without the disk. If none of this works or if you have ToT then I can try and send you the end movie and see if that makes a difference.
 
I have Civ 2 MGE. I've never downloaded any upgrades, nor known of any. What do you mean by "the no-disk crack"?
The fact that I can't even open that "WINWIN" video using RealPlayer tells me that the problem is something systemic, but I don't know. EVERY other video plays clean! And the game plays fine (though slower on XP for some reason).
I have plenty of hard disk space (don't we all these days?) if the eventual solution means dumping the CD to disk.

Hey, I appreciate your follow-up on this. Debugging in this way is tedious, but worth it in the end. Thanks.

Marty
 
I just tried something else, and to my surprise, it worked. I moved my CD from my DVD drive to my CD-RW drive. I was sure this would make no difference but it did.
Of course, now I need to know why it won't work on my DVD, but that may be a question for a different website.
On my other machine, I also have a DVD and RW, and always played Civ on the DVD without a hitch. Go figure, huh?
I had the same result with RealPlayer.... It failed to play just that one video on my DVD, but plays it on the RW.
Thanks again for the responses. This "fanatics center" is quite a site.
 
Top Bottom