Multiplayer Only Slow - Civ2 UIA.v.15.0.67 MGE

camvant

Chieftain
Joined
Apr 15, 2022
Messages
1
Hello fellow Civ members,

My friend and I both have the same version, Civ2 UIA.v.15.0.67 MGE and both of our games run perfectly fine in single player but when we attempt to create a Multiplayer game the game functions but at an incredibly slow speed (making a Multiplayer game practically impossible to play). It takes like 6 seconds to click on a unit, 8 seconds to move between each tile, and each AI takes about 15 seconds to complete their turn.

We both have Windows 10 and high-end computers, we've tried running in several compatibility modes, turning off full screen optimization, creating games with and without Hamachi, and nothing has deemed successful.

Will be following this closely, or if someone could reach out to me through Discord for resolution it would be greatly appreciated, we would like to expand the Multiplayer to other friends of ours but we have to find a fix first.

Discord: Piercesuxlol#7855
 

Buck2005

Prince
Joined
Feb 27, 2009
Messages
398
Hello fellow Civ members,

My friend and I both have the same version, Civ2 UIA.v.15.0.67 MGE and both of our games run perfectly fine in single player but when we attempt to create a Multiplayer game the game functions but at an incredibly slow speed (making a Multiplayer game practically impossible to play). It takes like 6 seconds to click on a unit, 8 seconds to move between each tile, and each AI takes about 15 seconds to complete their turn.

We both have Windows 10 and high-end computers, we've tried running in several compatibility modes, turning off full screen optimization, creating games with and without Hamachi, and nothing has deemed successful.

Will be following this closely, or if someone could reach out to me through Discord for resolution it would be greatly appreciated, we would like to expand the Multiplayer to other friends of ours but we have to find a fix first.

Discord: Piercesuxlol#7855

Hello! I faced this problem in one of the games. What is the reason - I do not know. This kind of delay in unit movement and AI queuing has only happened in one game with one specific player (out of so many people I've played with over the years). Therefore, I assume that the cause of the problem was on his side. Probably, this could be due to the peculiarities of the operating system of this player.

Alternatively, you can try using Radmin - an analogue of Hamachi.
 
Top Bottom