1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  3. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  4. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  5. Dismiss Notice
  6. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

NoAIPatrol Setting and conquests.ini on Mac

Discussion in 'Civ3 - Macintosh' started by Acronym, Jun 21, 2012.

  1. Acronym

    Acronym Chieftain

    Joined:
    Jun 17, 2012
    Messages:
    186
    Location:
    Scotland
    Hi there,

    I'm sorry if this has been asked before, but I've had a bit of a skim through the forums and didn't see it at first glance.

    I've just dug out CivIII again on my ageing MacBook and am looking forward to injecting a new lease of life into it by playing some of the GOTM's and PBEM games.

    However, I notice that the GOTM/COTM recommend setting the 'NoAIPatrol' setting to =0 in the conquests.ini file, in order to make Barbarian movement more random and consistent between players.

    I've had a look and I can't find this file anywhere on my computer. Does such a file exist for the Mac version, and does the bug exist in the Mac version? If it does, can anyone tell me how to change it? Finally, will this be a problem if I were then to play a PBEM game with someone else who hasn't changed this setting - or do most players change it nowadays?

    Thanks!

    PS - I'm playing Civ III Complete v1.22 Rev. A.

    ====
    EDIT: I've found the answer, kindly provided by AlanH, in a discussion rather hidden away in the General Discussion forum! For anyone that stumbles across here with the same question, find the answer here.
     
  2. megistatos

    megistatos Warlord of Mars

    Joined:
    Apr 8, 2006
    Messages:
    285
    Location:
    Hull, UK
    This is exactly the problem I'm having but the solution AlanH gives isn't working. I can't find the ~/Library/Preferences/Civilization 3 Complete/conquests.ini file.

    Did it work for you?
     
  3. AlanH

    AlanH Mac addict, php monkey Moderator Hall of Fame Staff Supporter GOTM Staff

    Joined:
    Jan 9, 2003
    Messages:
    28,955
    Gender:
    Male
    Location:
    England
    It should be there.

    Please note that ~/Library is a short hand for /Users/<your_user_id>/Library. It is NOT the /Library folder.

    What version of OS X are you running? If it's Lion or Mountain Lion then your ~/Library folder is hidden.

    Solution #1: Hold the Option/alt key down while selecting the Finder's Go menu, then you can select your own Library folder from that menu.

    Solution #2: Copy the following text: ~/Library/Preferences/Civilization 3 Complete/
    Then open the Finder's Go to folder... menu option and paste the copied text into the dialog. Click Go to reach the folder. You should find the Conquests.ini file in it.
     
  4. megistatos

    megistatos Warlord of Mars

    Joined:
    Apr 8, 2006
    Messages:
    285
    Location:
    Hull, UK
    Apologies for the double post and thanks a lot, I found the file. :D I'm on snow leopard so it was no problem at all once with you expanation.
     

Share This Page