1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Play / register Civ3 in general and on Mac OS X (Mojave 10.14)

Discussion in 'Civ3 - Technical Support' started by Faramir582, Jun 4, 2020.

  1. Faramir582

    Faramir582 Chieftain

    Joined:
    Jun 4, 2020
    Messages:
    8
    Hello,
    I´m new to this site, hopefully someone of you has some time for me question - maybe you´re using another OS and had the same problem?

    I played C3C for years on different Mac OS. Lately, I reinstalled Mojave 10.14 on an external drive, because this is the last system C3C runs on.

    I have my Registration key, but it doesn´t work. The last times, I just copied the 2 registry files to the new system and it worked, but now, the game is asking for the key. Since I know, the game is no longer supported by Asypr, maybe that´s the point? Also, I remember, you can register manually, but I can´t remember which numbers I have to leave of - I think you have to do something like that. I can´t find my email from Aspyr from that day, when I bought the game.

    I know the game works, also there was a patch, that supports newer OS till 10.14.

    If you´re reading this and don´t know an answer to my problem, maybe you know where I can get it or buy it? I didn´t find it on Steam etc.

    Thanks you for your time
    Stefan
     
  2. Faramir582

    Faramir582 Chieftain

    Joined:
    Jun 4, 2020
    Messages:
    8
    I solved it:

    You can buy the PC-version easily on GoG for 1,29€, that was frustrating first.
    But I used "Porting Kit" https://www.portingkit.com to run in on Catalina. It worked well and was very cheap. So I stopped trying to register my old copy again. After one year of looking for a solution, I´ve got one now.
     

Share This Page