1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. Photobucket has changed its policy concerning hotlinking images and now requires an account with a $399.00 annual fee to allow hotlink. More information is available at: this link.
    Dismiss Notice
  3. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  4. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  5. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  6. Dismiss Notice
  7. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

Please Wait....For Eternity.

Discussion in 'Civ5 - Technical Support' started by Ghonasiflaids, May 3, 2012.

  1. Ghonasiflaids

    Ghonasiflaids Chieftain

    Mar 15, 2012
    Hi. I am playing a modded marathon game (legendary earth with a few additional mods) as Genghis Khan, am on turn 937, took over everything but the Americas, and just started war on the Iriqous. However anything passed this, I get stuck on 'please wait', forever. It used to completely freeze except the mouse, so I had to task manager out of the game, so I tried going in windowed mode. In windowed mode I can move around the screen, even open up diplomacy screens and trade, but it stays on please wait and turn 937. I click on units and all of them have a fresh new set of turns, but when I give them orders it does nothing.

  2. FeiLing

    FeiLing Chieftain

    Jan 9, 2012
    Try setting all the graphics to very low.
    If that doesn't help maybe try to play from an autosave from a few turns earlier.
    Good luck (but I'm afraid it's not likely to be resolved).
  3. timtofly

    timtofly One Day

    Sep 28, 2009
    Have you tried strategic view. That may clear up some resources to get to the next turn

Share This Page