RAND 2.0 beta Gameplay and feedback

Discussion in 'Rise of Mankind: A New Dawn' started by JosEPh_II, Jan 21, 2012.

  1. Zootroy

    Zootroy Chieftain

    Joined:
    Jan 26, 2012
    Messages:
    4
    By "Religions disabled" I mean religions were not being founded when a trigger tech was discovered. I played a game into the middle ages thinking they were simply being founded on another continent faster than me but even after contact the entire world lacked faith.

    No permutation of Choose or Limited religions mattered. My default playstyle is to leave them off. Didn't fiddle with inquisitions.

    But I think you're right that it was a cache issue. I started up a ton of Blitz games as Indians so I could rush Hinduism to test different settings. After I tried toggling "Multiple Religions" in BUG they seem to be founding again, even when I set it back on a new game.
     
  2. antoca

    antoca Chieftain

    Joined:
    Nov 15, 2010
    Messages:
    98
    Location:
    Russia
    Caching can be good if you use only vanilla Civ4, but with mods, you know, they are not constant - so this is not good idea. I have disabled caching, and you can do it too, following instructions:
    1) Open CivilizationIV.ini (/Documents&Settings/User/My Documents/My Games/Beyond the Sword/ folder if you use winXP) in text editor.
    2) Look for strings:
    3) Edit them:
    3a) If you don't have such strings, just add them.
     
  3. Zootroy

    Zootroy Chieftain

    Joined:
    Jan 26, 2012
    Messages:
    4
    I only update a mod occasionally (Beta2 is the first time I updated AND since 1.75C) so disabling caching seems a little drastic... Is the cache located in one spot that's easy to just delete or force invalidation when I install an updated version?
     
  4. JosEPh_II

    JosEPh_II TBS WarLord

    Joined:
    Jun 20, 2007
    Messages:
    16,419
    Gender:
    Male
    Location:
    Western IL. cornfields
    Just hold down the Shift key while the Mod Loads.

    JosEPh
     
  5. zoob

    zoob Chieftain

    Joined:
    Jan 31, 2012
    Messages:
    65
    Location:
    Munich
    Hi.
    Wohoo, first post :)

    Let me introduce myself first of all. It started with me watching my cousin play Civ1 on a Amiga 500 somewhere in the beginning of the 90s. We played days and nights Civ2 at a friends house on his Pentium I. Strangely i skipped Civ3, although a tried it once. After a couple of years of playing FPS i returned with playing Civ4 v1.61. Afterwards i switched to BtS and got to know civfanatics.com and the huge amount of mods.

    Now it's my part to participate in the community!

    Really great work all ppl put into this modmod, especially Afforess. I have been completely stunned by it's complexity and all those features.

    As i want RAND to develope further, i give some feedback & critics. As there are zillions of positive ones already mentioned, i only write those that imo need to be fixed, or talked about.
    (RAND 2.0 beta 2, map size huge, all standard except "unlimited wonders", noble, Epic)

    - Slavery:
    Due to the heavy research drop (-33%) in civics from barter, research of slavery and instant switch is essential. As AI switches to slavery much later, they fall behind in tech (except they have PLENTY of resources at hand that give coin). Furthermore, i think 1 free slave in all cities is way too much production (although the slave doesn't even show up in the capital) early on. Small cities build things way too fast in early stage of the game). With Village Hall you already get a free specialist, for example a free slave.

    - Chiefdom: -50% maintainance doesn't show up in city screen (although Despotism gives +25% * 2 = +50%, which shows up)

    - Despotism: +1 unhappy for 10% foreign culture is maybe a bit much, as there is 99% foreign culture when you capture a city. city will drop to size 1 soon, as noone produces food. (happiness is rare early on). Maybe +1 unhappy for 25% foreign culture?

    - Caste: i never used it, it's way too weak.
    - Prophets: never used.

    - Petra: "can turn 1 person into priest" makes it possible to use the free specialist as priest, which would give 2 + 3 + 3 = 8 great ppl, too much imo. Plz remove it. Temple of Artemis is fine.

    - in AND Enhanced Civics Mod 1.0 a specialist gives +1 great ppl, which is good for not having those great ppl (great prophet/merchant) so fast early on who fix your economy when settled in a city.

    Okay, i think i's enough now, otherwise noone will read :)
     
  6. gunburned

    gunburned Warlord

    Joined:
    May 22, 2004
    Messages:
    139
    I was able to Launch an A-bomb before the Manhattan Project was complete,
    not shure if this is a bug or was intended.
    Is this normal?
     
  7. Aline

    Aline Cat

    Joined:
    Dec 10, 2007
    Messages:
    465
    Not sure but i think i have observed this aswell.
    The manhaten project was apparently changed from a world wonder to a national wonder(probly so you have to build it yourself to get nukes) but the effect that everyone can build nukes once it is build still remains.
    So aslong as anyone has built it you can build nukes even if you did not build "your" manhaten project.
     
  8. Slarki

    Slarki Warlord

    Joined:
    Aug 5, 2011
    Messages:
    232
    Is the revolution mod changed in any way?
    I captured a whole kingdom in three rounds (there were 5 cities).
    Normally, I can destroy any revolution. But now, each 3 rounds (!), they revolt. If I dont kill all enemies at once, they get overwhelming reinforcements. I play on prince difficulty..
    It isn´t possible to build that many troops to stop the revolutions..
     
  9. Dreifels

    Dreifels King

    Joined:
    Nov 21, 2001
    Messages:
    747
    Location:
    Europe
    revolution still is buggy. game crashes above round 720 somewhere, and I counted ore than 800 (!) barbarians growed new in one turn (giant map)
     
  10. Camarada78

    Camarada78 Chieftain

    Joined:
    Jul 26, 2009
    Messages:
    76
    I've done many great games without even researching Slavery. If you put your first Great Prophet as a specialist (+5 gold) you can get lots and lots of turns with 100% research.

    Despotism also give +1 happiness for each troop in a city. So, when invading a big city it is normal to leave a bunch of soldiers there.

    [/quote]
    - Caste: i never used it, it's way too weak.
     
  11. Jamz

    Jamz Chieftain

    Joined:
    Aug 25, 2007
    Messages:
    17
    I more or less given up playing with religions in the beta build, everything else works fine.

    I tried reinstalling the game and the mod, deleting the Civ.ini file, clearing my cashe. Also fooled around a bit with different settings in custom game. (i always play custom game full_of_recourses 3.0 map type, havn't tried doing a quick game yet, maybe i should try that.)
     

Share This Page