re-install the editor

Theov

Deity
Joined
Feb 11, 2008
Messages
2,664
Location
Taiwan
Hello,

when trying to open the Civ3 Complete editor, it gives an error saying it can't find the PTW destination.



Is there a way to only re-install the editor?
Or, does someone else know a solution to this?

Thanks!
 
i get the same pop up, I even tried your fix about running as admin, but still get the pop about the game needs to be installed...
 
i get the same pop up, I even tried your fix about running as admin, but still get the pop about the game needs to be installed...

Arashi1822, welcome to CFC! :band:[party]

Additionally try to set the compatibility settings of the editor to Windows XP (Service Pack 3).
 
i have win10 not XP
Yes, that's what "Compatibility mode" is for: using older software on newer systems.

Find the PTW Editor executable (Civ3XEdit.exe) in your installation, right-click on it, choose "Properties" from the menu, and then open the "Compatibility" tab (where I would also be given the option to "Run as Admin" on Win 8.1, so presumably also in Win10?).

Then choose the appropriate compatibility mode.
 
:yup: Yes, it was written for a Win10 user. I can only give you a screenshot of those Win10 settings in German language:

Win10Compabitility.jpg
 
Last edited:
cant get my screen shot to work, but I did as instructed and still getting that error
 
I had these editor problems with Civ 3 Complete several times with win 7 and with win 10 on my pc. In all these cases, these problems happened after an update of windows 7 or 10 (I cannot say anything about win 8, as I don´t have it) . They were always solved by running the editor as administrator and by setting the compability in windows for the editor to the windows XP service packs 2 or 3.

Arashi1822, here ends my knowledge about this problem and I wish you good luck in solving it.
 
Is there a way to only re-install the editor?
Or, does someone else know a solution to this?
No, the Editor is fine, it's the game that seems to have a problem.
The installer writes the following Windows Registry Key:

HKEY_LOCAL_MACHINE\SOFTWARE\Infogrames\Civ3PTW

which contains a number of values, for example
Install_Path = <where you installed Civ3>

When Windows introduced 64bit, the Registry was split in two parts: one for 32bit programs (like Civ3) and another one for the new 64bit programs. (No idea, why Microsoft did this, in my opinion, it only causes problems and confusion...)
Anyway, in a 64bit Windows installation, the keys for the old 32bit programs are now found in a special sub-folder, e.g. in our case:

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Infogrames\Civ3PTW\Install_Path

And also, in newer Windows version, programs sometimes need special permissions to access the Registry.

So what does this mean for our problem? The above error message "Could not locate Civilization III: Play the World. Please make sure the game has been properly installed" looks to me like the Editor is trying to read the above Registry Key (in order to find out in which directory all the art files, maps, etc. can be found), and for some reason doesn't find that key. It then assumes, that the game has not been installed... Why is the key not found? There are two possible reasons:
  1. The key is there, but the Editor cannot read/find it. (E.g. because of 32/64 bit registry mismatch, missing permissions, etc.)
    These kinds of errors are probaly solved by what Civinator mentioned above: run the Editor in "XP Compatibility Mode" (solves problems with 32/64 bit registry confusion) and run it as Administrator (solves permission problems).
  2. The key does in fact not exist.
    If the tips above didn't help in your case, then this is probably what happened in your case. You can check this by starting the program "RegEdit" as Administrator and then checking, whether the following path is there:
    registry.png

    Note: in addition to this one, I found two more, which may also be relevant:
    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Firaxis Games\Civilization III - Complete Edition\INSTALL_PATH
    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Infogrames Interactive\Civilization III\Install_Path

    Probably this depends on which exact version/edition of Civilization III you have installed.

    If none of these exist, the next question is: why? I learned recently that only programs that run as Administrator, are allowed to write to the Registry. So if you did not run the installer with admin permissions, it would not have been able to write its registry keys, and this would explain why the Editor now cannot find them.
    Solution would then be to reinstall the game, but this time as Administrator.
    You could also try to create these three keys manually and fill them with the correct directory, where you installed the game, but I doubt this will be successfull. Chances are, there are a couple dozen other keys, that the game and/or Editor also expect, and which are still missing...
 
Hi

So I've got the same problem.
(Compatibility doesnt work for me, admin neither)

But how can I install it as admin if I use Steam to install the game ?
It is steam that does the installation so I dont see how to change the process.
 
Seems right.
But it did work on previous installations. Did Steam change its modus operandi ?

If you have some input on what steps to take to fix this ?
 
Most probably your problem is, that the Steam edition only includes C3C (no PtW at all)?
Does the C3C Editor work?
I tried the Conquest editor v1.48 but it doesn't fully work : I cannot seem to manage to modify any save with it / import then save.
I can import some BIQ settings, but never does it let me :
- get a map (from a saved game)
- export/save any real file if I imported previously.
- Modify a saved game (with the option where you need to select both files).


And seriously why doesn't this work :
- Screen is the game editor, in play the world, which doesn't work but I have no idea why : it is literally in the folder.
(And by extension why doesn't it find the files in the C3Complete Editor?)

anyway if you've got some link / tips... I'm not good with these issues.
But I guess Conquest Editor 1.48 is enough for now.
 

Attachments

  • Editor Bug.jpg
    Editor Bug.jpg
    93.2 KB · Views: 4
Last edited:
As I said: the Steam edition does not include the PtW executable. (And presumably does not create the registry keys in which the editor looks for the installation directory (to find the art files).

But the C3C Editor looks fine: afaik, it was never able to edit .sav files. (For this you need some of the tools available in the Creation & Customization forum, like Gramphos' old toolkit, if that still runs on a modern Windows?!)
 
Top Bottom