• Civilization 7 has been announced. For more info please check the forum here .

RFC: BtS Bug Reports

Hitti-Litti

Deity
Joined
Sep 8, 2006
Messages
3,767
I'll start this thread, I think that it will be useful.

Played as Khmer. I built two cities, Phnom Penh and Hue. I started to explore with my galley, and when it reached the southern tip of India, the game crashed. Unfortunately no save, though it was about turn 10 only.
 
Shame on you, Firaxis! Shame on you! Sh-h-h-h-h-h-h-ame.
 
I tried to play as England last night. The game kept crashing/quitting after a few turns of play. This has only happened with RFC so far- no other mod in BTS appears to have this problem. Once a message came up about a video memory problem (or something), but I already had the graphics and video quality set on Low, and even after I turned off the wonder movies the game still kept crashing.

What can I do??:confused:
 
Playing as Persia, and then switched to Russia. Played few turns as Russia and when I try to load game- I can't. Loading screen just stands there. I can upload a save.
 
I've tried playing two games so far and during both I lost contact with civilizations! See attached pictures of one game.
Turn 59 I've already met India en here Babylonia shows up.
Turn 80 I lost all contact with Babylonia and Asoka is acting like he's meeting me for the first time while we have open borders and traded techs.
(No such problems with the rest of BtS)
 

Attachments

  • Civ4ScreenShot0014.JPG
    Civ4ScreenShot0014.JPG
    120.8 KB · Views: 690
  • Civ4ScreenShot0015.JPG
    Civ4ScreenShot0015.JPG
    106.5 KB · Views: 661
Ah..thanks for the quick reply. Trade techs asap before the opportunity is lost, right? I'll better do some more reading about this game first before playing the next round.
 
In BtS, one of the quests i received called for my building 11 colosseums, which is naturally impossible as it is a world wonder. I assume it means 11 ampetheaters.
 
"You will build those 11 colosseums and be damned with the costs man!"

Probably is Amph based on the fact those are the "normal" equiv to BtS
 
Hey Rhye I'm getting a crash on loading a late game civ (Russia) after having started in the 3000bc variant as Greece.

Here's the attached save. It makes me a sad panda.
 

Attachments

  • Peter AD-1760 Turn 311.CivBeyondSwordSave
    1,017.3 KB · Views: 417
Thus far the crashes only happen when playing your mod.:(
If I download your mod seperatly it will be solved??

I've had similar CTD problems with Final Frontier as well- clicking on some leaderheads or meeting some leaders in-game causes a crash-to-desktop.
I think the CTD problems in RFC might also be leaderhead-related but I'm not sure.

I hope a patch to address these problems is released soon!:(

PS Rhye, because of this problem, your BTS mod is basically unplayable at the moment, which is a shame because it's a damn good mod!
 
I've had some CTDs as well. One was after popping a hut and finding a map and then another was when selecting a warrior and getting an endless sound loop that eventually crashed me. I'm blaming Firaxis for now. :)
 
I keep getting crashes if i mouse over the mercenaries button, I tried to ignore but i can't miss it when trying to alter research rate:(
 
Not a bug exactly, but a need fro modification. Goals within BtS appear to be based on 11 of anything, which within RFC is undesirable to say the least.

Is there a more reasonable number?
 
Top Bottom