1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  3. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  4. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  5. Dismiss Notice
  6. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

[R&F] Rise and Fall: No City Nameplates, not using mods

Discussion in 'Civ6 - Technical Support' started by drunkpunk, Mar 13, 2018 at 1:33 PM.

  1. drunkpunk

    drunkpunk Chieftain


    Since the latest patch to the game, I am experiencing an issue that I cannot seem to solve. So far my email to 2k support is taking some time to get responses that haven't been remotely helpful, and I've pretty much exhausted all other resources for tech support at this point, so I'm hoping someone here might be able to help me out.

    Any Rise and Fall game I create, load or join, I am no longer able to see my city nameplates. This only occurs with Rise and Fall, but with every Rise and Fall game I create, join or load, both single and multiplayer. I have never used mods with civ (fairly new player, started when 6 released), so mods aren't a direction I've gone yet. Everything I google about this goes back to mods, so I wanted to make that part clear.

    This is what I see: https://i.imgur.com/wlGmyC1.png

    As you can see, I get the little bar for encampments, but nothing for cities. Here is another example of a fresh game: https://i.imgur.com/SIQj3Fw.png

    Now the weird thing is, in the middle of the maps, I see what appear to be a collection of city nameplates, even telling me the name of the nation that I have not yet met: https://i.imgur.com/RQPzfXz.png

    You will also notice that the research and civics tab show some screwy stuff. Playing some games, sometimes this will correct itself but for the most part it always shows Research 33 turns and does not accurately indicate the research or the time left. Also, in multiplayer games, while I experience this, the other people who connect do not.

    As I had mentioned before, I have never used mods before, I have tried verifying my files, defaulting my settings, reinstalling the game and nothing has worked. It's pretty tedious doing things like checking on city loyalty, having to click on cities to see various bits of info I'd usually get great feedback on, etc. Especially with loyalty. Does anyone have any ideas on how I might solve this?

Share This Page