Robert's Guide to Installing Civ2 Vanilla to 64bit Computers (Win 7/Vista/XP)

Robert FIN

Nov 7, 2012
How to run Civ 2 "Vanilla" on 64 Bit Computers (Win 7/Vista/XP):

Hello forums! I've noticed that people's only question in here in Civ2 Tech Support forum has been; How in the earth they can play Civ 2 on Windows 64 bit?? Well there are many, many, many quides to do this but here is my attempt to make this so easy that even an idiot can do this. If you failed to do this, please tell me what is the problem and let's see if I can help. I used Andu Indorin's post to solve the problem, most of the quotes are from him. However I try to make the post to quide form and add some details on it. I did write this quide at the same time when I managed to make this work in the 1st time in my life!

Let's fail start!

Needless to say, direct attempt of installing Civ2 "vanilla" directly to a Windows 7 64bit computers is a failure. However, copied all files from this old, old CD-ROM (that's read-only-memory for those who haven't had a history lesson in obsolete technology) directly to hard drive (... MPS\Civ2 directory).

This part is easy. Just put the Civ2 disc to CD-drive (E:/), and check the contents of your E:/ drive. Do this by opening the windows menu from down-left corner of the screen and press "Computer" and go to your E:/ drive.

You see a couple of directories in your E:/ drive. There is "CIV2", "Extras", "VFW_INST" and "WING" directories and Program called "Setup". You have to copy the directory which is called "CIV2".

Now go to your C: drive from the windows menu on down-left corner of the screen and press "Computer". Create directory called "MPS" to your C: drive. Fill your new directory by pasteing the CIV2 directory there (the one you just copied). Now you should have your CIV2 directory in C:/MPS and C:/MPS/CIV2 should be filled of files from your CD.

NEXT, Downloaded Cedric's five-part MGE patch conversion -- -- and manually copied (i.e., overwrote) those files into the same directory.

This is the part where I failed in the first times. So, follow this link and get Cedric's five parts file-arsenal to convert your Civ 2 "vanilla" to Civ 2 Multiplayer Gold Edition. Otherwise you cannot play Civ 2 on 64bit programs. CIV 2 VANILLA MUST BE CONVERTED TO CIV 2 MGE TO MAKE IT WORK ON 64BIT COMPUTERS!!

Its easy, download the five zip. files from there and check your downloads. Double click the 1st part of Cedric's zip. arsenal. Double click the directory what is inside the zip. You find a file or many files there. Copypaste the files into C:/MPS/CIV2 folder. Repeat this to all 5 zip. files. If windows asks if you want to replace a file that already exists, just say yes to all. Then we are ready with this step. If you try to launch Civ 2 exe now, windows won't deny your access to it but the game still won't work. We have to do something more!


THEN followed the above directions:

Now we should have Civ2 Multiplayer Gold Edition on our /CIV2 directory. Then we need Mastermind's patch which allows us to get our game really working. Get it here:

Mastermind's Patch vol 2.0!!

Once you get it downloaded, follow these instructions, this part is all my text:

After all, Mastermind's program is easy to use. However, everyone is not so good in computer things that this part would be easy. At least I as a noob was asking Mastermind all the time "How to do this??" and "How to do that" before I made a breakthrough. Here we go:

1. Open the program.

2. Press the button, right side to text "Civ 2 Exename".

3. Then you see your CIV2 directory (if you don't, just find it from C:/MPS) and select exefile called civ2.exe.

4. Press patch.

5. If it says that CIV2 is now patched you are ready with this part. Close program.

*Note1*: If it says that civ2.TMMbak file already exists, go ahead and delete the file manually from C:/MPS/CIV2 folder.. And try again!

*Note2*If it says that it cannot patch, you probably failed with zip files part. Tell us details then.

Now you're done with Mastermind's program. Next I tell you how to start your Civ 2 MGE. This part must be done probably every time when starting Civ 2 in future. Me again:

I'm not sure if it starts smooth with your computers now but I have to do these steps always while starting Civ2. Skip this part if it just goes straight to main menu.

1. Find civ2.exe from /CIV2 folder. Double-click and give it rights to continue, Civ2 won't hurt your computer :lol:!

2. You get black screen with waiting cursor. Hold down "Alt" button on and quickly click TAB button. Keep Alt down during this step! Now you can switch to screen with Civ 2 main menu without the options (Named Civilization 2 Multiplayer Gold).

3. You see main menu without options now. Do Alt>TAB again and this time choose the smaller black screen. In my computer its the one in left of the nameless black screens.

4. Big black square appeared on to center of main menu. Now just left click it.

5. Civ 2 started like a dream.

6. Test it and if it works, just play and have fun!

Now you should have working Civ 2 game on your computer. WOOHOO!! Have fun! After this it worked for me. However some people have to do step 4 too, so read it for being sure that your Civ2 works.

#4: For some people who weren't able to load saves after getting the game working:

Could not load saved games. Fortunately, from another thread in this tech support section regarding ToT Saved games, a solution was offered:

goofydink: I use winxp here. I had the same problem that is mentioned here. What I found out is that the saved game files need to be saved in a different folder than what comes up as the the default save folder. TOT in my case has the default save folder as C:\Microprose Software\Civilization II Multiplayer Gold Edition. The saved games would not load from here. When i saved a game to to C:\Microprose software, it loaded fine. So in my case anyway it is a pathing issue. I hope this is helpful.

SO, for simplicity sake, created a Microprose Software folder in the C:\ directory, and copied the Civ2 directory from Windows 7 "default" Program Files x86 directory to the new folder. Problem solved: saved games now loading.

Done. Now you should have working Civ 2 MGE in your 64 bit Computer :banana::dance::banana:!!! (You have Win 7/Vista/XP most likely.)

Let's think what we did: First we had 16bit program which won't work in 64bit machines. We transformed it to 32bit program with Cedric's zip files. Then we patched it to work with Mastermind's patcher. That's All!

If you have problems, post to this thread and we'll try to help.

As reward I don't ask anything but possible sticky rating so everyone who needs this could find it much easier way.

At last, I'd like to thank all people who made this possible. If your name isn't in the list and you feel like you deserved it, just call me and I'll fix that. Millions of thanks to these people who made my quide possible:

Prof. Garfield, for help me getting started with the issue,

Cedric Greene, for making Civ 2 MGE- upgrade zip. files and telling us how to use 'em,

MastermindX, for programming MGE patcher to us and for helping me to use his program,

Andu Indorin, for the amazing post what I did quote the most in this quide,

goofydink, for solving save loading issue,

You, for reading this quide,

Everyone I forgot to mention.

Written by:

Robert FIN

Thanks for reading :worship:!!
Thank you Thank you and Thank you!Nice tutorial and long life to Civilization 2!!!
I though it would be very hard, but you have explained it very well :)
Thank you Thank you and Thank you!Nice tutorial and long life to Civilization 2!!!
I though it would be very hard, but you have explained it very well :)

Thanks for saying thanks, ender28 :)! I'm glad that someone found the guide useful. Have you had problems with aggressive AIs bug and lack of working videos? No worries. Some people have solved those problems already, so I will add them to my guide soon.

EDIT: Cannot do this because I'm now running Linux on my computer, cannot test these things anymore. Maybe someone can add these fixes here..
Yeah!! Looks like we have a sticky rating for this thread now! I'm super pleased! Thanks for the one who made it possible. I promise to hurry the expansion!

EDIT: No expansion, because I'm running Linux now, so I cannot do any research about this anymore...
I just wanted to thank you for this extremely useful thread/post.

I only had to use the first three steps (it starts up just fine; I just have to hit the space bar once to bring up the opening Civ 2 menu screen, and there was no issue with saved games either).
I just wanted to thank you for this extremely useful thread/post.

I only had to use the first three steps (it starts up just fine; I just have to hit the space bar once to bring up the opening Civ 2 menu screen, and there was no issue with saved games either).

Good to hear that the guide has been useful :)! Makes me smile.
After a long period of frustration because I couldn't play Civ2 on my W7 64bit laptop I finally stumbled across this thread.

Just wonderful! Everything works (a couple of obscure instructions here and there but "common sense" saw me through those - eventually ;) ).

I've now finally got to grips with the "Events.txt" file for use with scenarios and am having fun making my own. Encountered some odd behaviour with those files but I'll probably post about those elsewhere.

Anyway, my main reason for posting is to thank everyone whose efforts have made this possible. Civ2 was the first real computer game I played and it's great to still have it available.

On a side note I've been annoyed by the fan noise while playing the upgraded version and decided this morning to try the "CPU throttle" posted on another thread. Much to my surprise it worked first time with no messing about. Still haven't fully tested that with saving and loading etc but first impressions are excellent. So if you haven't tried it yet then do.

The main problem I'm having with scenarios at the moment is that some of the download scenarios, i.e. the multi-stage ones, require a program called "delevent.exe" to modify the .sav file after each stage. Unfortunately that program doesn't seem to run on 64bit machines. Does anyone have a suggestion? I believe the file simply removes the event information from the save file from the previous game stage so that the new event file can be used when the .sav file is reloaded. If I knew what it was doing exactly I could probably write such a program myself.

Anyway, enough rambling for now and thanks again to everyone who's made all this possible.

Edit The CPU Throttle also cures the wonder video/skipping/sound scratching problem I'd been having. Great!
Just another bump and "thank you" to all who made this possible and for this guide.

I stumbled upon my old CivII disc in a junk bin after a move and thought I might like to try playing again. Hard to believe the game is 18 years old this year! Wow!
Bumping this thread, because... scenarios don't work. :( I'm trying to play with the old scenarios, such "The World of Jules Verne", but it just crashes right after setting up the options. I don't know if there's still someone that can help me in this. :(
First off, thank you so much for putting this all together. I've been playing again for the first time in years entirely because of this post so truly thank you! I don't know if anyone still checks these but just in case I thought I would post. Everything works great except the Wonder Videos and the High Counsel. The window pops up but it's just black. As for the High Counsel their text appears but there are no images or video responses. Just black squares. I was hoping there was a fix as I love the videos. I'm running this on Windows 10. Thanks everyone!
Thank you so much, this was super helpful!
I just joined the forums today in search of a solution to a problem I've encountered... after just a few minutes of game-play, a tutorial pop-up will come up and then it will not let me click 'ok' or do anything else. So I become stuck. I've tried double-clicking, pressing enter, esc, starting a task manager, but to no avail. The first time this happened it was telling me to build a second city. The second time it told me I should try mining some hills. I can drag the box around, just can't move on from it.

I'm not sure whether this is a bug that can be fixed, or whether it is my computer. I have a dell XPS 13 laptop, just recently upgraded to windows 10. I notice sometimes the game starts to slow down just before this happens.

Again, I'm new to this community so I apologize if this has already been answered somewhere, and any help is appreciated!:)
I'm afraid I've not encountered that problem ... but then again I don't have Windows 10 yet and have not played with the tutorial popups in a long time. Unless you really feel you need them you can turn them off by unticking that box in the Game Options list (in the Game menu).
That's okay, thanks for the advice; I'll try that. It's just been such a long time since I've played the game I thought it would be helpful to leave them on... but I think I should be fine without them... I'll see how it goes!
Hi Guys,
new to the thread here. I have windows 10.

Downloaded CIV 2 off Moderator Action: Abandonware is considered piracy here. Please don't link to it. The_J

It had a patch included, and I got to the menu, except as soon as I got to the select which civilization u want to be it keeps crashing. saying, 'civ2.exe has stopped working.'

It's really annoying and I just want to play civ 2! Any ideas??:mad:
Last edited by a moderator:
darkestvalley, I had an old patch for CIV2 called Civ278. I just replaced the files of the patch with the original game files before step 2. I'm not sure where to get this, but it solved the problem.
can anyone help.
i cannot install test of time on windows 10 64bit.
thanks in advance.
unbelievable, i close skype and the game installed normally!!!!!!!!!!!!!!!!!!!!!!!!!
Thank you. Got Civ2 working properly using this guide.

Here's a shortened version of the guide though :)

1. Go to your Civ2 CD and copy 'CIV2' directory to your hard drive (I use C:\Games), so you have something like C:\Games\CIV2
2. Copy and replace all files from the zips Civ2MGE1 to Civ2MGE5 to your C:\Games\CIV2 directory. (files here..
3. Run Civ2XP64Patcher, select the Civ2.exe and patch. (patch here..

Just one thing though, how do we fix the aggressive AI bug in MGE when installing with this guide? I tried the attitude.exe patch but it only causes game crashed while playing?
Unfortunately, the link to Cedrics files has broken with the move to the new forum, and I cant find them anywhere in the new downloads section. Grateful if anyone can give me a working link! Many thanks!
Top Bottom