1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. Photobucket has changed its policy concerning hotlinking images and now requires an account with a $399.00 annual fee to allow hotlink. More information is available at: this link.
    Dismiss Notice
  3. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  4. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  5. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  6. Dismiss Notice
  7. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

Running out of hair to rip from my head

Discussion in 'Civ4 - Technical Support' started by King Flevance, Oct 27, 2005.

  1. King Flevance

    King Flevance Chieftain

    Joined:
    Oct 26, 2005
    Messages:
    4,612
    Location:
    Kansas City, MO
    ATI Card issue....

    OK, I am running a desktop 2.7Ghz P4, 760M ram, with the ATI All-in-Wonder 128M vid card. (No AGP so my ancient butt is stuck with low grade PCI cards) According to these reqs things should be working.
    Here is a brief discription of my issues:

    After finally getting it to install and play, I run into an extremely dark environment, crawling gameplay, and Leaders are floating eyeballs and a set of chatter teeth. I check the options and eeverything seems normal, (no downgrades and such; I even took them down a notch to see if it would help and I saw no change)

    I know CIV 4 is having ATI problems as its all over forums right now. I have tried a few solutions including the one that includes Pakbuilder that seems to have worked for everyone under the sun except me. I know I am pouting but Sid Meier just ripped me off IMO. It seemed odd that Civ 3 came out years after 2 and 4 pops out right after 3.

    I dont want to gripe really, I just wanna play this game I payed almost 60 bucks for. If anyone has any information as to what I can try it would be apprecited every little bit helps and I am out of ideas and suggestions now. I have been working on this all day and still cant play and tired of having to do what firaxis should have done before release...troubleshooting.
     
  2. general_kill

    general_kill Chieftain

    Joined:
    Apr 14, 2003
    Messages:
    2,870
    I have good news, I just saved a bunch of money by switching... oh never mind.

    Dude, civ 4 did not "pop out" right after 3, civ 3 was released 4 years ago. I'd say just wait for the patch or spend money on NVIDIA.
     
  3. King Flevance

    King Flevance Chieftain

    Joined:
    Oct 26, 2005
    Messages:
    4,612
    Location:
    Kansas City, MO
    Maybe it just seems that way. I will admit that.
    Through surfing thru the forums, it seems this is a well known problem with alot of people. I have the chesire cat/ dark terrain problem as well. Hopefully they release something on this.
     
  4. Knight-Dragon

    Knight-Dragon Unhidden Dragon Retired Moderator

    Joined:
    Jun 25, 2001
    Messages:
    19,958
    Location:
    Singapore
    Moderator Action: Moved to CIV Technical. :)
     

Share This Page