1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  3. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  4. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  5. Dismiss Notice
  6. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

Solution To Detonatorxp Scrolling Problems

Discussion in 'Civ3 - Technical Support' started by Camelmaster, Nov 23, 2001.

  1. Camelmaster

    Camelmaster Chieftain

    Joined:
    Nov 16, 2001
    Messages:
    26
    Location:
    Massachusetts, USA
    Major kudos go to 'kcbrown' from the www.apolyton.net boards. I saw this fix there, and so I thought it was so good that I should show it here, too. Here is his original message. This did the trick for me!
    ------------------------------------------------------------------------------------
    Here's how you fix this problem.

    1. Go to http://www.guru3d.com/files and click on Videocard Drivers, then NVIDIA detonator drivers. You'll be presented with a list of drivers.

    2. Grab the Detonator 12.41 WHQL drivers that are appropriate for your platform. The drivers are in the form of an executable, but at least for Win2K you can open it up in your zip file handler program (I use Powerarchiver myself, but most people use Winzip).

    3. Extract the nvoglnt.dll file into the directory that Civ3 is installed (i.e., the directory that the game executable resides in). This works under Win2K, as executables seem to pick up DLLs first in the home directory of the executable, then the system directories. This might not work everywhere. If it doesn't have an effect, then you'll have to place it in your system32 directory or system directory (wherever your current nvoglnt.dll file resides).

    This procedure worked for me. Give it a shot...can't hurt...
     
  2. Nothappy

    Nothappy Chieftain

    Joined:
    Nov 24, 2001
    Messages:
    1
    I would hardly call having to use obsolete drivers a solution...there have been too many major improvements in the drivers since then to use such dated ones.

    I don't know about anyone else, but I've been using the 12.41 drivers today just to play Civ 3 without choppiness and I'm experiencing several annoyances in XP like web pages scrolling choppy (what irony) and graphical glitches in high end 3D games.

    I hope Infogrames fixes the problem because obviously any new Nvidia drivers will not make a difference.
     
  3. Camelmaster

    Camelmaster Chieftain

    Joined:
    Nov 16, 2001
    Messages:
    26
    Location:
    Massachusetts, USA
    The thing is, you /don't/ have to use obsolete drivers. You put that one file in your civ 3 folder, and you can use the up to date NVIDIA drivers. Civ 3 will use the old driver, while every other program uses the new ones.
     
  4. Typo

    Typo The Rabid Prince

    Joined:
    Sep 17, 2001
    Messages:
    39
    Location:
    Great Britain
    I tried this and it does improve the scrolling. It still isn't smooth scrolling though (still scrolling frame by frame) unlike when playing with hardware acceleration turned down.

    I hope Firaxis fix this problem soon as its annoying the hell out of me.
     
  5. kcbrown

    kcbrown Chieftain

    Joined:
    Nov 25, 2001
    Messages:
    6
    I experimented with turning down hardware acceleration and found that it didn't seem to have any effect at all compared with using the older Detonator OpenGL DLL. Strange that we're seeing different behavior resulting from the same actions...
     
  6. Camelmaster

    Camelmaster Chieftain

    Joined:
    Nov 16, 2001
    Messages:
    26
    Location:
    Massachusetts, USA
    Hey KCBrown. Once again, thanks for the fix. It's working like a charm now, and I can play all my graphics intensive games with new drivers.
     
  7. Typo

    Typo The Rabid Prince

    Joined:
    Sep 17, 2001
    Messages:
    39
    Location:
    Great Britain
    How far did you turn it down, it basically needs to be turned off. Taking it down a notch or two makes no difference (On win2k I have it one up from lowest setting). The game flys on this setting although I'm not sure what all side effects might be...
     
  8. kcbrown

    kcbrown Chieftain

    Joined:
    Nov 25, 2001
    Messages:
    6
    I experimented with all settings, including turning hardware acceleration completely off. At the point where most of the acceleration was turned off (and below), I got the same performance that I get with the older NVidia drivers. At anything higher than that it would exhibit the slowness bug.

    In no instance would it scroll smoothly (as opposed to jumps of one square).
     

Share This Page