1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

[SOLVED]"destroyed" my game? (crash before menu)

Discussion in 'Civ5 - Creation & Customization' started by Serp, Apr 18, 2020.

  1. Serp

    Serp King

    Joined:
    Apr 1, 2015
    Messages:
    615
    I just shot my game :D...

    What I did:
    Had mods loaded, firetuner open and then changed the "Name" from an InGameUIAddin EntryPoint in a modinfo. This lead to immediate crash and now I can not start the game anymore (crashes after loading screen, before main menu).

    Tried to solve:
    I deleted whole cache folder, but still does not work.
    I also checked game files via steam, it replaced 3 files.
    But the game still crashes...

    No DLC-Modpack installed.

    Running Visual studio attached to civ gives me, that the callstack is in "msvcr90.dll", so maybe I somehow destroyed this dll?!

    Anyone as an advice how to fix this?!

    edit:
    deleted the whole civ 5 folder in MyGames folder solved the problem. Willl try to find out what exactly it was.
     
    Last edited: Apr 18, 2020
  2. Serp

    Serp King

    Joined:
    Apr 1, 2015
    Messages:
    615
    hm.. it is my mod that I currently build, that is causing the crash, only for being in my mod folder, the game will crash.
    Guess I made a typo or sth in the modinfo, that caused the crash, but cant find it, last thing I changed is the "Name" of my InGameUIAddin:

    Spoiler :

    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <Mod id="28B6FCBC-12EF-9A50-1892-29A764B9555E" version="1">
      <Properties>
        <Name>StratBuildMalus</Name>
        <Teaser>Buildings that require a ressource, will stop producing for every missing ressource</Teaser>
        <Description>Buildings that require a ressource, will stop producing for every missing ressource. Stops exploit by simply buying (trade) coal, build Factory and loose ressource - no malus.</Description>
        <Authors>Serp</Authors>
        <HideSetupGame>0</HideSetupGame>
        <AffectsSavedGames>1</AffectsSavedGames>
        <MinCompatibleSaveVersion>0</MinCompatibleSaveVersion>
        <SupportsSinglePlayer>1</SupportsSinglePlayer>
        <SupportsMultiplayer>1</SupportsMultiplayer>
        <SupportsHotSeat>1</SupportsHotSeat>
        <SupportsMac>1</SupportsMac>
        <ReloadAudioSystem>0</ReloadAudioSystem>
        <ReloadLandmarkSystem>0</ReloadLandmarkSystem>
        <ReloadStrategicViewSystem>0</ReloadStrategicViewSystem>
        <ReloadUnitSystem>0</ReloadUnitSystem>
      </Properties>
      <Dependencies />
      <References />
      <Blocks />
      <Files>
        <File md5="2EFFAAC9FBD462E13747230C8EE3C2F5" import="0">StratBuildMalus.lua</File>
      </Files>
      <Actions>
      </Actions>
      <EntryPoints>
        <EntryPoint type="InGameUIAddin" file="StratBuildMalus.lua">
          <Name>StratBuildMalus</Name>
        </EntryPoint>
      </EntryPoints>
    </Mod>
    

    edit: found it, the Actions should be look like this, if it should be empty:
    <Actions />
    edit2:
    no the crash reason was indeed the InGameUIAddin, it needs a "Description" otherwise it crashes... stupid. <Description>StratBuildMalus</Description>
     
    Last edited: Apr 18, 2020

Share This Page