1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

STEAM Update Issues On Windows 8/McAfee

Discussion in 'Civ5 - Technical Support' started by rover68, Oct 30, 2014.

  1. rover68

    rover68 Chieftain

    Joined:
    Oct 23, 2014
    Messages:
    17
    I have been unable to access BNW CIV5 since the 10/27 update on my Windows 8 PC.
    Each time I try to access the game, a receive a message from STEAM Stating:

    I have re-started the PC, I even disabled McAfee real time scanning, scheduled scanning, and firewall. Nothing changes.

    Oddly, on my Windows 7 Laptop with AVG, I can access it ok.

    Has anybody else had this problem or is familiar with it?
    If so, do you know how to resolve?

    If not, is there anyway or place I can go to get some service?
    STEAM has no live technical support, I've posted this on numerous message boards, and this is not the first time I've had STEAM cause unresolved issues.
    I find the whole customer service model very frustrating, as the burden is on the user it appears to be the IT Tech.
     
  2. rover68

    rover68 Chieftain

    Joined:
    Oct 23, 2014
    Messages:
    17
    I uninstalled McAfee on my Windows 8 user account, re-started the PC.
    The SAME exact problem happened!
    Now what!?
     
  3. rover68

    rover68 Chieftain

    Joined:
    Oct 23, 2014
    Messages:
    17
    Same issues.............
     
  4. rover6695

    rover6695 Prince

    Joined:
    Aug 5, 2014
    Messages:
    437
    AHAHAHAHA...I got it!

    OK, so I uninstalled CIV5, tried to re-install, would not work.
    I uninstalled STEAM and tried to re-install, would not work.

    I then, took a break, downloaded google earth for desktop and guess what...that too WOULD NOT connect to the internet.
    So THEY unlike STEAM had clear directions, one of which was PROXY SETTINGS!

    I went to
    a) Under "Tools" in the browser tool bar select "Internet Options".

    b) In the "Internet Options" Window that pops up, click the "Connections" tab at the top.

    c) Click "LAN Settings" near the bottom of the "Connections" section.

    d) If the "Proxy server" checkbox is marked with a check, click it to deselect/uncheck it.


    It now works!
    Amazing...so it was as I figured a WINDOWS problem.
    Once again I am reminded of why I will never ever buy a Windows OS product.

    This whole thing COULD have been solved quicker if STEAM actually had a live person I could talk to....

    Moral?

    1) Windows sucks
    2) STEAM sucks
     

Share This Page