[NFP] Successful Multi Player Start Up for Civ 6 (PC Mac)

General Bendek

Dec 25, 2011
Screenshot (333).png

When attempting to load Civ 6 Multiplayer, my friends Mac will load for an hour, without ever loading the game...
What are potential solutions to this?

My PC is successfully loading and playing Civ 6 Multiplayer with other friends, so I assume all of my game updates, and hardware requirements are functioning correctly.

We have tried
Me as host.
Him as host.
Using the same Wifi.
Playing over the internet.
Unified PC play.
Keying in the invite code manually.
Invite to Lobby through Civ 6.
Invite to Play through Steam.
Invite by dragging his Steam profile into the game on Steam...

Still no load.

We both have Steam set to update automatically.
We both have Frontier Pass.
We are not creating games that have barbarian clan mode etc. or any content that might not have been including in Frontier Pass.
Standard Rules.

We do have different Version Numbers.
My Checksum: (846892)
His: (some numbers) Metal

Could the 'Metal' difference cause a no load? Is there a way to address this?
Last edited:
Top Bottom