1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

TCP/IP Failing to Connect For MultiPlayer Game in WIN 10

Discussion in 'Civ2 - Technical Support' started by Paul Mowbray, Jul 25, 2016.

  1. Paul Mowbray

    Paul Mowbray Chieftain

    Joined:
    Jul 24, 2006
    Messages:
    1
    Hi Folks-

    My friends and I have been playing CIV II online for several years. One of the crew recently upgraded from WIN 7 to WIN 10. He re-installed CIV II and that works fine in single player mode.

    However, when he attempted to join our multiplayer game in progress......the dreaded message came thru.... "Game machine failed to connect." Made numerous attempts to connect as well as checking online to see what the issue was.

    Has anybody had this issue and if so how is it resolved.

    Thanks in Advance.
     
  2. DaringPaw

    DaringPaw Chieftain

    Joined:
    Sep 6, 2016
    Messages:
    35
    Hey there. I have the same issue. Have Win 10. Using Hamachi. And Civ 2 MGE. Fails to connect while others can connect. Considering makeing an win xp or win 7 partition or using virtual box.

    Has anybodey solved this problem on plain Win 10? Any thought or help appreciated. Thx.
     
  3. DaringPaw

    DaringPaw Chieftain

    Joined:
    Sep 6, 2016
    Messages:
    35
    Ok, to run Civ2 on Windows 10 basis, I managed to set up a workaround: A virtual machine with Virutalbox with Win XP OS and Civ2 and Evolve in it. Works perfectly fine. Establishing the internet connection was a bit of work though. But finally it works. Yay!
     

Share This Page