1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. Photobucket has changed its policy concerning hotlinking images and now requires an account with a $399.00 annual fee to allow hotlink. More information is available at: this link.
    Dismiss Notice
  3. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  4. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  5. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  6. Dismiss Notice
  7. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

The BUG mod + Next War?

Discussion in 'Civ4 - BTS Unaltered Gameplay (BUG, BAT and BULL)' started by Fuscusager, Jun 11, 2011.

  1. Fuscusager

    Fuscusager Chieftain

    Joined:
    Jun 11, 2011
    Messages:
    6
    Location:
    Genoa (Italy)
  2. Lemon Merchant

    Lemon Merchant Smarticus Pantsidae

    Joined:
    Jun 27, 2008
    Messages:
    4,363
    Gender:
    Female
    Location:
    Red Sector A
    Which version of BAT do you have installed? The link you referenced says it needs BAT 2.1. There have been radical changes to BAT as of version 3, so it definitely won't work with BAT 3.0.1.

    I honestly have no idea if this will work, since you're using Steam. Unfortunately, we are unable to support every configuration of Civ, since we can't test for every type of installation. We're also unable to support other mods which use BUG or BAT in some way. There are simply too many of them.

    My advice would be to contact the modder that made the Next BAT War mod, and see if he/she has any suggestions on how to make this work with Steam.

    Please post back and let us know if you were able to find a solution, as there still might be something that we can help to make it work, but we need a little more detail, please. :)
     
  3. Fuscusager

    Fuscusager Chieftain

    Joined:
    Jun 11, 2011
    Messages:
    6
    Location:
    Genoa (Italy)
    ok, i'll try to send a pm to the user that create Next BAT War.

    i've try both BUG 4.4 and BAT 3.0.1

    the steam installation create the Documents\My Games\Beyond the Sword folder like the standard cd install.

    the game folder are located in steam\steamapps\common

    the BUG 4.4 mod is working fine with the Steam installation, but it only works when i start a new game with the standard Civ4 BTS with no mod active.
    when i try to start a new game with Next War and only the BUG 4.4 installed the game show no user interface, and it's impossibile to play:sad:

    i think that if the BUG works ok with a steam installation, it's possible to have it working ok with Next War... but i'm a common civ4 user only, i've no ideas how modding anything :D

    ps: sorry for my bad english :crazyeye:
     
  4. Lemon Merchant

    Lemon Merchant Smarticus Pantsidae

    Joined:
    Jun 27, 2008
    Messages:
    4,363
    Gender:
    Female
    Location:
    Red Sector A
    It won't work with BAT 3.0.1. Only 2.1.

    Don't worry about your English, it's just fine. :)
     
  5. EmperorFool

    EmperorFool Chieftain

    Joined:
    Mar 2, 2007
    Messages:
    9,633
    Location:
    Mountain View, California
    Cammagno merged BUG with Next War a ways back (I don't remember which version of BUG), and you should be able to find it in this thread. The problem is that it has its own custom Python which interferes with BUG.
     
  6. Fuscusager

    Fuscusager Chieftain

    Joined:
    Jun 11, 2011
    Messages:
    6
    Location:
    Genoa (Italy)
    thanks a lot for yr answers!

    but which thread? there is no link in the post :)
     
  7. EmperorFool

    EmperorFool Chieftain

    Joined:
    Mar 2, 2007
    Messages:
    9,633
    Location:
    Mountain View, California
    This thread has an old (BUG 3.6) merge as a good starting point.
     
  8. mqduck

    mqduck Chieftain

    Joined:
    Mar 10, 2002
    Messages:
    68
    Location:
    Mountain View, CA, USA
  9. lucidstorm

    lucidstorm Chieftain

    Joined:
    Dec 25, 2016
    Messages:
    31
    Gender:
    Male
    @mqduck
    unfortunately that link you provided isn't working, can u make a google drive (or whatever suits you) link for Next BAT War download?

    thx
     
  10. xaster

    xaster Chieftain

    Joined:
    Oct 5, 2003
    Messages:
    124
    @mqduck was not seen here in the last nearly 2 years :shifty: I also plan to combine the BUG Interface with the Next War Python code and looking for some reference!!
    Is somebody here who can upload Next BAT War once again ??? the download link is broken.
    Or help me with the code please!

    I have problemes to get the code working in CvGameUtils.py
    Code:
        def cannotConstruct(self,argsList):
            pCity = argsList[0]
            eBuilding = argsList[1]
            bContinue = argsList[2]
            bTestVisible = argsList[3]
            bIgnoreCost = argsList[4]
          
            # player can't build an arcology if they have shielding or advanced shielding
            if eBuilding == gc.getInfoTypeForString("BUILDING_ARCOLOGY"):
                if pCity.getNumRealBuilding(gc.getInfoTypeForString("BUILDING_ARCOLOGY_SHIELDING")) or pCity.getNumRealBuilding(gc.getInfoTypeForString("BUILDING_DEFLECTOR_SHIELDING")):
                    return True
          
            # player can't build shielding if they have advanced
            if eBuilding == gc.getInfoTypeForString("BUILDING_ARCOLOGY_SHIELDING"):
                if pCity.getNumRealBuilding(gc.getInfoTypeForString("BUILDING_DEFLECTOR_SHIELDING")):
                    return True
    
            return False
    
    I have enable
    <Define>
    <DefineName>USE_CANNOT_CONSTRUCT_CALLBACK</DefineName>
    <iDefineIntVal>1</iDefineIntVal>
    </Define>
    in the PythonCallbackDefines.xml but the code is not working.

    BUG have an own handler for GameUtils called BugGameUtils.py, please can you help me to get this code working with BUG !?? :bowdown:
     
  11. xaster

    xaster Chieftain

    Joined:
    Oct 5, 2003
    Messages:
    124
    I get i CANNOT_CONSTRUCT_CALLBACK ................. WORKING !!!

    K-Mod/BUG Mod do not load the CvGameUtils by default :eek::mad::mad::mad::mad: you need to config BUG about it !!!

    add code to Assets\Config\init.xml
    Code:
      <gameutils module="CvGameUtils" class="CvGameUtils"/>

    and yes the callback needs to be enable in Assets\XML\PythonCallbackDefines.xml as well.
     

Share This Page