The Dreaded Editor Error

AnthonyBoscia

Emperor
Joined
Feb 7, 2010
Messages
1,715
We've all seen this trash before...

re-install the editor

GOG Complete Suddenly Needs PTW???

Civ3 Editor Can't Find Game

Problems with editor on Civ 3 Complete (Steam verison)

I have had this error randomly and independently occur on the disc, gog, and steam versions of the game. I've seen no clear evidence on my computer or on cfc as to what exactly causes this. I've set the editor to be compatible with xp service pack 3, and 2, and win 7, and every other combo I could think of to no avail. The editor is run as admin and still does not function properly. The most current time this has happened, I've made no changes to anything civ-related on the computer since the last time it worked properly.

Has anyone got an idea as to what causes this error? What makes the editor suddenly incapable of finding the file path for items which haven't moved? And the fact that fixes for it seem to work at some times and not at others? Transferring 100 gb of mod info each re-install is not an acceptable solution. Thanks.
 

Quintillus

Archiving Civ3 Content
Moderator
Supporter
Joined
Mar 17, 2007
Messages
7,481
Location
Ohio
I agree with Civinator that there's a leprechaun... or maybe a gremlin... shipped with the editor. It had been working fine on my computer. Yesterday, I fired it up, and got the "ERROR: Could not locate Civilization III: Play the World" message, and all the cascading errors afterwards. According to Windows Update, I have not installed any updates since March 12th, and I've definitely used the Firaxis editor since then, so the "Windows Update breaks it somehow" theory does not apply in my case.

So... I have no idea what changed. I checked the registry, and the install path is still correct there. And... running as admin actually works for me. Why that works for me, but not for Anthony, I have no idea.

This general error (it had happened for me in the past as well, though not for several years), is why I made sure the error message my editor throws when it fails to find a resource at least tells you what it tried to access, so there's some possibility of figuring out how things went wrong.

:dunno: It's really weird. I may be a software developer, but it's baffling to me.

I do wonder if anyone ever ran into this issue before Windows Vista? My best guess is it's some really weird edge case of Windows permissions that were introduced with Vista, and I see all the threads you found were recent (though I'm sure I saw earlier ones than that... just not sure quite how early). Still, I'd guess even if Mike B (the author of the original editor, who's lurked at CFC as recently as a few years ago) saw this, there's a good chance he'd legitimately have no clue what's going on due to it not having been possible when he worked on the editor.
 

AnthonyBoscia

Emperor
Joined
Feb 7, 2010
Messages
1,715
When I looked at my last windows update I thought along similar lines. Although I do think it's windows-related. Does this issue happen on Mac as well?

It's working for now on a new install, but again we can only wonder when this issue will return, like Civ herpes. Civinator's explanation of gremlins or turret gnomes is probably a more appropriate description.
 

Civinator

Blue Lion
Supporter
Joined
May 5, 2005
Messages
7,871
Leprechauns, gremlins, turret gnomes. :think: Not long ago, the monitor of my pc showed the following creature:

Leprechaun.gif
 

Quintillus

Archiving Civ3 Content
Moderator
Supporter
Joined
Mar 17, 2007
Messages
7,481
Location
Ohio
When I looked at my last windows update I thought along similar lines. Although I do think it's windows-related. Does this issue happen on Mac as well?

It's working for now on a new install, but again we can only wonder when this issue will return, like Civ herpes. Civinator's explanation of gremlins or turret gnomes is probably a more appropriate description.

There isn't a Conquests Firaxis editor on Mac, so by default it doesn't. I think there is a Vanilla editor for Mac, though? If so, I haven't heard of it happening there... but I'm also not sure if anyone's been modding Civ3 Vanilla on Mac in recent years.

New Civ install, or Windows install? The former isn't too terrible if it's a reliable fix, but I wouldn't reinstall Windows to fix it (although I did re-install Windows to fix Vista-and-Civ-related issues a few times back in the day).
 
Top Bottom