1. Firaxis celebrates the "Asian American and Pacific Islander Heritage Month", and offers a give-away of a Civ6 anthology copy (5 in total)! For all the details, please check the thread here. .
    Dismiss Notice
  2. Old World has finally been released on GOG and Steam, besides also being available in the Epic store . Come to our Old World forum and discuss with us!
    Dismiss Notice

Trade screen does not work

Discussion in 'Civ6 - Technical Support' started by MicroManiac, Aug 11, 2021.

  1. MicroManiac

    MicroManiac Chieftain

    Joined:
    Nov 25, 2006
    Messages:
    2
    Didn't play Civilization for a while and just started a new game. Installed the latest updates. Now I have a problem with the trade screen that does not work. I added a screenshot of the screen I get when attempting to make a deal with the AI. None of the buttons work. Anyone else experiencing this problem? How do I fix it?
     

    Attached Files:

  2. Browd

    Browd Dilettante Administrator

    Joined:
    Aug 5, 2012
    Messages:
    11,966
    Gender:
    Male
    Location:
    Rural Vermont
    First debugging question: Are you playing with any mods? Mod conflicts are probably the most common source of game glitches.
     
  3. MicroManiac

    MicroManiac Chieftain

    Joined:
    Nov 25, 2006
    Messages:
    2
    Thanks for the suggestion. I reinstalled the game, which did not help. Then I restarted with all mods disabled and it works now. So still need to find out which of the mods is causing the issue.
     
  4. Laurana Kanan

    Laurana Kanan Don’t underestimate who I am. Moderator

    Joined:
    Apr 10, 2014
    Messages:
    3,623
    Gender:
    Female
    Location:
    Near the Greatest Snow on Earth
    If you enable all your mods & start a game, you can look for any error or warning messages in your database, modding, or lua logs located at "..User Files\Documents\My Games\Sid Meier's Civilization VI\Logs" to help track down the problem. Alternatively, if you want to post a list of the mods you're using here, someone might be able to pinpoint the issue.
     

Share This Page