Turns until next scientific advance?


Dec 13, 2001
Chicago USA
:crazyeyes I'm going goofy trying to figure out what line on the hex editor with a .sav file sets the number of turns until the next scientific advance is completed. Can anyone help me as to where this is done? :cry:
I haven't really tried looking into the .sav file and looking at the values stored there, so take this with a grain of salt...

But it seems to me rather ludicrous to store this value in a save file, as it can be easily calculated in game by comparing the amount of trade being developed per turn at the time and the amount researched so far versus the tech's cost.

What probably is stored is the amount of beakers that have gone into researching the current technology so far, much like there's no value stored for turns to finish an improvement but rather the amount of shields that have been accumulated so far.

If you mean you want to change the minimum amount of turns for discovering a tech as defined by the .bic being used by the save game, try seeing which values the editor changes.

You'd probably be well advised to do a search on gramphos spots as he and others (who I can't remember) have been posting about the contents of .bic and .sav files they've uncovered from using hex editors. Someone might have already done the work for you!

Good luck in your search though :)
Thanks for your reply. Actually what you are saying makes sense as the number often changes throughout a turn, either way the .sav game must save whatever variables are used for this calculation, and these are the numbers I am looking for. And upon which line they are located. What I actualy am trying to do is make it so that it (an advanace) never is developed. I have been playing around with Eric Tan's c3edit32.exe and using it to select all advances. With nothing to research the computer is locking up if you go to the science advisor (so I learned not to go there). For the first couple of hundred turns the computer pretended to be researching "bronze" (even though it is already discovered), each time showing the value "--" on the gamescreen. Suddenly one turn it starts counting and once it becomes "discovered" the game locks up (I have been unable to determine what causes it to start counting after so many turns without counting).:rolleyes:
Well, I'm not completely clear on what it is you want to do.

If you want a particular advance to never get researched in the game, at all, so that whole tech line it belongs to gets disabled? So that no one has this advance? If so, just go to the editor and set the era to "none" this will make it thoroughly unavailble, at least as far as my testing has concluded.

(note: the editor claims you can still get the advance if you select it as a starting tech for a civilization, which is utterly false. I tried for countless hours for that setup up to work, and it never did.)

If however, what you want to do is make it so that only you can have a particular advance and you don't want the AI to have it, then the best solution would be to:

a) increase the max turn to get an advance to something insane, like say 100 and put it at the end of the tech tree, and increase it's cost to 1000 (the max allowed). That should stall the PC and you just get it as a starting advance.

b) If that's not thourough enough for you, you can make 20+ prereq advances each with a 1000 cost, all of which are not required to advance to next era and link them up so they finally lead to that one advance.

c) Just delete all qualities associated to that advance including buildings and units that use it as a prerequisite and edit it out of the tech tree by changing the pre-reqs of other techs. Essentially taking it out.

Hope one of those works for you! Or maybe I totally didn't understand what you meant :confused:

oh wait, you're giving yourself every single advance? So basically the PC is crashing because it's looking for something to research?

Edit the value of integrated defense to 1 (so you can research it fairly quickly once the game starts), then give yourself every advance but this one, change what you're currently researching to that one advance and then research that one, this should enable you to start researching future techs, which should void that nasty crashing problem!

You might also want to check on just how stable the game is when you give yourself techs. There have been several instances where editors don't change every single value needed to correctly make changes in the game. Like giving yourself palaces in every city doesn't reduce corruption, nor does it change the center of the empire, as this is done after the wonder is built by calling some in game function it seems. (probably part of the fix to eradicate the palace-less empires)

Tech advances might be somewhat similar. Is this function of that editor thoroughly tested? I might be interested in using it for the mod I'm building, where i"m trying to give every civ special "characteristics" by giving it advances only it can possess, thus making every civ more unique. But like I said before, the whole setting a tech to "era: none" just eliminated it from the game completely, so I couldn't even give it to the civs as starting techs! =/

Anyways, good luck with your endeavour :)
Top Bottom