1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  3. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  4. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  5. Dismiss Notice
  6. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

Unit graphics flipping

Discussion in 'Civ4 - BTS Unaltered Gameplay (BUG, BAT and BULL)' started by duckstab, Jun 5, 2016.

  1. duckstab

    duckstab Child of Noble Family

    Joined:
    May 5, 2008
    Messages:
    1,401
    Gender:
    Male
    Location:
    Austin, Texas
    I'm suddenly seeing an issue with unmodded BAT 4.1 as well as with my personal mod based on BAT. The attached screenshots illustrate what I'm seeing. In the first screenshot you'll notice that the Explorer unit bottom center is correctly rendered but the Explorer in the upper left corner shows the original default graphics. In the second screenshot I've moved the first Explorer onto the Sheep. You'll see that now the other Explorer is selected and is now correctly rendered while the previous unit has now reverted to the default graphics.

    one0001.JPG

    two0000.JPG

    I figure this must have something to do with graphics being paged out and then back in, but I know next to nothing about how that works or what the possible corrective action might be. Thanks in advance for any help anyone can offer!
     
  2. duckstab

    duckstab Child of Noble Family

    Joined:
    May 5, 2008
    Messages:
    1,401
    Gender:
    Male
    Location:
    Austin, Texas
    Well, I managed to fix it. It turns out the game had been switched to low-res graphics. I'm guessing that maybe my graphics card was misbehaving at one point and the game switched itself to the low-res setting, sticking there.

    It doesn't really explain why the active unit was being drawn correctly, but whatever.

    If you ever run into this problem, check your settings on the Graphics tab under Options.
     

Share This Page