1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. Photobucket has changed its policy concerning hotlinking images and now requires an account with a $399.00 annual fee to allow hotlink. More information is available at: this link.
    Dismiss Notice
  3. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  4. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  5. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  6. Dismiss Notice
  7. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

Units Glitching Between Skins

Discussion in 'Fall from Heaven: Age of Ice' started by Carrot Iron, Feb 13, 2015.

  1. Carrot Iron

    Carrot Iron Chieftain

    Joined:
    Feb 13, 2015
    Messages:
    7
    Here's a unique issue I've been having:

    My units glitch back and forth between skins. For instance, the scouts turn into their native-esque CIV IV look whenever I click on them, command them to move, or are attacked. They will occasionally turn back into their original sleeproll-toting shirtless-in-winter selves when left alone, but re-selecting them causes the effect once more. Same thing with my starting warriors, axemen, etc.

    Another fantasy-breaking but hilarious glitch is that this also occurs with enemy units, IE: frostlings look like miniature hoplites on the field rather than the little icy creatures they should appear as.

    I do not have BUG installed, and am running BTS unmodified ATM that I run via Steam on a Windows 7 OS. Tried making a separate shortcut and run as admin, which worked to open AoI directly, but failed to solve the problem. It occurs each time when I play any game of FfH: Age of Ice.

    Any ideas? Perhaps I'm missing something simple?
     
  2. lfgr

    lfgr Chieftain

    Joined:
    Feb 6, 2010
    Messages:
    549
    You need to disable "frozen animations" (or something called similar) in the Ctrl-O Graphics menu.
     
  3. Carrot Iron

    Carrot Iron Chieftain

    Joined:
    Feb 13, 2015
    Messages:
    7
    Worked 100%. Thanks. Hope this can help others as well.
     
  4. xaosseed

    xaosseed Chieftain

    Joined:
    Jan 14, 2009
    Messages:
    15
    Location:
    Nigeria
    Wow - this has been driving me crazy for about four years now... finally - back to Erebus!

    Thanks both for the fix and for the clearly titled issue thread!
     

Share This Page