1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. Photobucket has changed its policy concerning hotlinking images and now requires an account with a $399.00 annual fee to allow hotlink. More information is available at: this link.
    Dismiss Notice
  3. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  4. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  5. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  6. Dismiss Notice
  7. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

Upload failed / this is not a valid image file

Discussion in 'Site Feedback' started by Bibor, Mar 4, 2011.

  1. Bibor

    Bibor Doomsday Machine

    Joined:
    Jun 6, 2004
    Messages:
    2,302
    Location:
    Zagreb, Croatia
    As of today I'm getting these weird messages:
    Upload failed (for ZIP and TXT) or
    not a valid image file (for JPG, PNG, GIF)

    if I try to add an attachment to my either new or previous posts. Help?
     
  2. Whomp

    Whomp Keep Calm and Carry On Retired Moderator

    Joined:
    Dec 17, 2004
    Messages:
    18,198
    Location:
    Chicago
    We're looking into this problem.
     
  3. ainwood

    ainwood Consultant. Administrator

    Joined:
    Oct 5, 2001
    Messages:
    30,060
    Not sure what's causing this. Will continue to investigate.
     
  4. vicawoo

    vicawoo Chieftain

    Joined:
    Feb 12, 2007
    Messages:
    3,226
    I can't upload civ 4 saves either, tried quite a few times with a few different saves.
     
  5. Catfish

    Catfish Chieftain

    Joined:
    Nov 2, 2003
    Messages:
    1,384
    Location:
    Wollongong, Australia
    MIME type issue. Getting the following message on the SL wiki for PNGs:

    Check with your host.
     
  6. NickyJ

    NickyJ Retired Narrator

    Joined:
    Dec 19, 2009
    Messages:
    5,568
    Location:
    The Twilight Zone
    I am trying to upload a new avatar, but after I click "save changes", the site gives me an error that says "Invalid File". I checked the image, and it is within the requirements. I then tried to upload my old avatar, but it gives the same error message for that as well. Is there something that I am doing wrong that is causing this?
     
  7. WilliamOfOrange

    WilliamOfOrange Chieftain

    Joined:
    Jul 17, 2003
    Messages:
    998
    Location:
    Lincolnshire, UK
    Alright, so it's not just me then.
     
  8. classical_hero

    classical_hero In whom I trust

    Joined:
    Jan 30, 2003
    Messages:
    33,209
    Location:
    Perth,Western Australia
    So it appears when the server had it's recent downtime, it caused a few problems.
     
  9. Whomp

    Whomp Keep Calm and Carry On Retired Moderator

    Joined:
    Dec 17, 2004
    Messages:
    18,198
    Location:
    Chicago
    In the short run, for those of you trying to load saves you might want to use this site.

    http://www.sendspace.com/

    For screenshots there's always imageshack and photobucket.
     
  10. Bananijoe

    Bananijoe Chieftain

    Joined:
    May 5, 2008
    Messages:
    29
    Location:
    Germany
    Hi,
    i just tried upload 2 small files containing xml- and lua-files
    a) Improved_Build_Queues_(v6b).7z
    b) InGame.7z

    as attachments to these 2 Posts:
    MOD-Incompatibility: Active City Defense (v 2)
    MOD-Incompatibility: Improved Build Queue Mod

    I get these error-messages
    when i try to upload them from a directory: "Upload of file failed."
    when i try to upload them from an URL: "Upload failed due to failure writing temporary file."

    Is there a Post-Number-Limit for attachments, is that an error, does anyone else has this problem?
     
  11. CivGeneral

    CivGeneral Valkyrie Cybernetic Grand General

    Joined:
    Jun 17, 2002
    Messages:
    42,489
    Location:
    Solitude, United Systems of Nova Terra
    Right now, there is an issue with uploading into the database. As noted from the announcement on the top of the forum. The solution I can offer is to use an external file hosting site.

    Imageshack, photobucket, and imgur are suggested for images
    Filefront (now known as gamefront) and dropbox are suggested for files like zip, 7z
     
  12. The_J

    The_J Say No 2 Net Validations Retired Moderator Supporter

    Joined:
    Oct 22, 2008
    Messages:
    29,836
    Location:
    Germany / Netherlands
    Moderator Action: Threads merged.

    Funny, but you're wrong. The file database is not affected by the issue (out of whatever reason), "only" the normal attachements.
     
  13. CivGeneral

    CivGeneral Valkyrie Cybernetic Grand General

    Joined:
    Jun 17, 2002
    Messages:
    42,489
    Location:
    Solitude, United Systems of Nova Terra
    Then what about uploading avatars via an external site, since I recall Superbeaver tried it and gotten the error something on the lines of can't write temporary file.
     
  14. The_J

    The_J Say No 2 Net Validations Retired Moderator Supporter

    Joined:
    Oct 22, 2008
    Messages:
    29,836
    Location:
    Germany / Netherlands
    :dunno: some things are affected, some not.
    The file database is an addon to the vBulletin forum, so there's purely technical a chance that it might not be affected by whatever bug we're encountering here.
     
  15. Catfish

    Catfish Chieftain

    Joined:
    Nov 2, 2003
    Messages:
    1,384
    Location:
    Wollongong, Australia
    Not just forum attachments: uploads for the hosted wiki sites are affected as well. It seems to have happened after the recent downtime. If it's a problem with Atomic Gamer's server settings, then you're barking up the wrong tree.
     
  16. CivGeneral

    CivGeneral Valkyrie Cybernetic Grand General

    Joined:
    Jun 17, 2002
    Messages:
    42,489
    Location:
    Solitude, United Systems of Nova Terra
    I did a quick google search and came across this:

    Not sure if this would help
     
  17. Catharsis

    Catharsis remember to buy eggs

    Joined:
    Feb 15, 2007
    Messages:
    4,946
    Gender:
    Male
    Location:
    Clinging onto underside of forum
    April avatar switch is going to be fun this year.
     
  18. CivGeneral

    CivGeneral Valkyrie Cybernetic Grand General

    Joined:
    Jun 17, 2002
    Messages:
    42,489
    Location:
    Solitude, United Systems of Nova Terra
    Yeah.... ....about that. I suspect its going to take a long time to fix it (I've seen similar issues on other forums where it got resolved in a matter of days) I'd think many people would start raging against the forums because a write permission and/or missing directory is the culprit (or whatever borked the uploads during the downtime).
     
  19. Vaidd

    Vaidd Worker

    Joined:
    Jan 4, 2011
    Messages:
    53
    Location:
    Nebraska
    I think we should all post random guesses about what's going on. :D Here's mine:

    I've seen similar issues before where the problem was that the inodes on the affected filesystem had been exhausted. Of course, this assumes you have a UNIX-based server on the backend, and that you have a dedicated filesystem that only stores uploaded files and doesn't affect other parts of the forums. In short, this probably wasn't any help at all. :(

    In all seriousness, I know you folks are working hard to solve the problem. Thanks for all you do to keep the forums up and running. :goodjob:
     
  20. Lone Wolf

    Lone Wolf Chieftain

    Joined:
    Dec 4, 2006
    Messages:
    9,833

Share This Page