• Civilization 7 has been announced. For more info please check the forum here .

Version 1.21f Crash to Desktop

Kingpin

Captain-General
Joined
Dec 21, 2001
Messages
700
Location
Canada
Has anyone experienced a repeatable crash back to the desktop without any warning messages of any kind?

If I reload to a saved game, it crashes again at exactly the same time.

Yes, I admit that I have modded my game, however, the crash takes place before any of the modified units can be researched. I have checked for obvious misspelled folders, ini files and such with no luck.

Here's what I have found out: I used Gramphos' tool to reveal the entire map. The crash occurs, in that game, when an AI scout moves.

Before I blitz my Civ III installation and re-load it, has anyone had that happen with an un-modded 1.21f? It would really suck if I deleted all my mods onlyto find out that it is a 1.21f thing and not related to adding mods.
 
hey, Kingpin.
if you have any modified buildings, check them. if you do not have the right source, pcx files for every building then the game will crash as soon as the AI builds them.
hope that helps.
 
x11,

I haven't modified any buildings or added any.

The only thing I have modded is adding units and adding two or three futuristic technologies.

Hmmm... I wonder if I am supposed to as civilopedia entries for those techs... Perhaps it's tech related and not unit related.

Any thoughts, anyone?
 
I have had that happen to me before, but when I tried to build a coloseum that I made into a small wonder. I think your problem may be that the AI is building some of the modded units or buildings. check that out.
 
Any units I have added I have tested by adding them into a game using Gramphos' tool. They all work fine.

I have not modded any buildings.

I have added three techs onto the end of the Modern age.

Any additional thoughts?
 
I had the same error happen now a few times. Any of my games always crashed shortly after all civs had contact to each other?? Can this be a reason for a game crash? I literaly played a game where noone had contact to one civ(I placed it in anarctica) and the game works fine. ???
I also saw that the game is crashing when I upgrade certain units, like the warrior.
Did anyone experience this kind of problem?
 
No, I haven't had that happen like that. I don't adjust civ placement at all.

I used Gramphos's tool to reveal the map so I could see what was going on when it crashed. In one case, an AI worker would move onto a gold resource, then CRASH. It happened every time I went back to a saved game at exactly the same turn because of that worker.
 
I decided to just uninstall Civ III, delete it's folders, and start over.

So far, so good. Any mods I have added work well.

Thanks to all of you who tried to figure out what I had gooded up. If anyone else has had this trouble, please post your experiences. It would be interesting to discover a solution for those still plagued with this...

Kingpin
 
Top Bottom