Vista 64-bit keeps loosing my preferences

Discussion in 'Civ4 - Technical Support' started by GatlingGun, Sep 20, 2008.

  1. GatlingGun

    GatlingGun Warlord

    Joined:
    Feb 3, 2008
    Messages:
    273
    Location:
    Northwest USA
    I'm having a bit of a wierd problem... I'm running BTS patch3.17 on Vista 64-bit Home Premium.

    When I ran this under XP, I could always count on my old settings (such as disabling full-screen mode, or that I prefer to play on Prince) as being saved from my last session.

    Then I went out and bought a new Shuttle with a Wolfdale processor to handle the insane loads that Civ puts on my old system (which was no slouch about 4 years ago)... and I bit the bullet and went with Vista... ever since I installed BTS under Vista I will routinely loose my previous settings after I close the game.

    I have tried making BTS run as an Administrator to no avail...

    So two questions...

    1) How does BTS keep track of my previous setttings?

    2) Any thoughts on how I can fix this?

    Thanks!
     
  2. auldian

    auldian King

    Joined:
    Nov 5, 2004
    Messages:
    648
    Location:
    Alaska, USA
    Mine are in \\Users\<user name>\Documents\My Games\Beyond the Sword. It's a CivilizationIV.ini located in the BtS folder in My Document > My Games. A backup of it is also created with a .bak extension. You can delete both to create a fresh copy and reselect your options from there.

    My hidden cache folder is on my system drive (C:) at C:\Users\<user name>\AppData\Local\My Games\Beyond the Sword. That should be cleared if you make changes, in my experience. At the least, it can't hurt.
     
  3. GatlingGun

    GatlingGun Warlord

    Joined:
    Feb 3, 2008
    Messages:
    273
    Location:
    Northwest USA
    Thanks auldian,

    I deleted all the files in the cache subdirectories and then I tried starting BTS but had the same problem.

    After I deleted CivilizationIV.ini and copied CivilizationIV_ORIGINAL.ini to CivilizationIV.ini it seems to have fixed the problem.
     

Share This Page