• Civilization 7 has been announced. For more info please check the forum here .

Win 7 64b msvcr71.dll error

Andy S

Chieftain
Joined
Feb 20, 2010
Messages
2
I bought Civ4 back before Christmas from D2D, but haven't been able to get it running. Win 7 64 Pro. Installed as admin, and attempting to run as admin. In path: C:\games\Civ4 as recommended here (uninstalled and reinstalled to that location with the same issues).

"The program can’t start because MSVCR71.dll is missing from your computer. Try reinstalling the program to fix this program."

That's the error I get when trying to run the game. I copied that dll file from an old install into both the windows\system32 and windows\sysWOW64 folders and tried to run the game, but it's still not working. Tried to regsvr32 (as admin) the file and it gives me an error.

"msvcr71.dll was loaded, but the DllRegisterServer entry point was not found."

Still won't work. Dug around and found this which sounds exactly like what I was doing, still doesn't work.

From what I understand, the msvcr71.dll is a part of .NET 1.1. I didn't really want to install that old version of .NET if I didn't have to.

Any ideas? Very frustrated. Uploaded the DxDiag.txt in case that might help.

Q6600, 8GB Ram, Nvidia GTX260
 

Attachments

  • DxDiag.txt
    36.5 KB · Views: 209
Andy,

I just encountered your error today I'm running same os and download game from same place.

This is what I did and it started working:

Download msvcr71.dll AND msvcp71.dll (appears as if after doing the fix with the first .dll i received an error with second one, double check to make sure this isn't happening to you as well)

After you download them place them in the c:\windows\system32 folder & c:\windows\sysWOW64 folder (I'm not a techy and I'm not sure which registration caused it to work)

open up command prompt:

type "regsrv32.exe c:\windows\system32\msvcr71.dll" (do not type quotations or this message)

If you get an error that says "loaded but entry point not found" you're good to go AFTER the next step

type "regsrv32.exe c:\windows\system32\msvcp71.dll" (do not type quotations or this message)

you'll get the same error as the above.

However....

When you go to run CIV IV... walla, it will work.

Now, I included the .dlls in the syswow64 folders as well. If it doesn't work after registering both dll's on the system 32 folders, do it with syswow64 folder. Same command, just different folder.

Some people claim doing it to their sys32 folder worked for them, but it was syswow64 folder that worked for me!

Feel free to hit me up on email wooglesboogle@gmail.com to let me know if this worked, I want to know I helped :p.
 
I haven't tried downloading the individual dlls but .Net it incompatible with Windows 7. I have been running tests with another game launcher regarding the same issue.

There are a few work arounds to get .net 1.1 to install

One way, although verification hasn't been done, is to just turn off User account controls. This requires a restart when you turn off and again when you turn them back on. Download the redistribution and sp1 files and run them as administrator.
Turn your UAC controls back on.

Another way requires a little work.

.Net doesn't like being overwritten and can cause issues. Microsoft has a blogger that has two tools you might want to check into.

.Net Verification Tool (downloads as netfx_setupverifier_new)
.Net Clean Up Tool 2.0 (downloads as dotnetfx_cleanup_tool)
The clean up tool should only be used if normal uninstall from programs and features shows .net framework 1.1 and it won't uninstall from this location.

Basically you'll want to create a directory dotnet on the C drive. You do this for ease of install
download the .net 1.1 redistributable to the directory you created.
download the .net 1.1 sp1, but save as dotnetfxsp1 (this makes the command line work easier)

Now run CMD as Administrator
the following commands can be put in line by line or in a batch file

cd\
cd dotnet
dotnetfx /C:"msiexec.exe /a netfx.msi TARGETDIR=C:\DotNet"

dotnetfxsp1 /XP:C:\dotnet\netfxsp.msp

msiexec.exe /a C:\dotnet\netfx.msi /p c:\dotnet\netfxsp.msp

netfx.msi

You will get prompts and warnings if UAC is on. Just choose to install and run program when prompted.

Make sure to run windows update when you finish this install to get the security patch for .net 1.1
 
FYI all that is required for Windows 7 64bit is to download the following .dlls: msvcr71.dll and msvcp71.dll from http://www.dll-files.com/. Then place them in the C:\Windows\SysWOW64 folder only. Neither require registration. After that Civ4 opens without issue.
 
FYI all that is required for Windows 7 64bit is to download the following .dlls: msvcr71.dll and msvcp71.dll from http://www.dll-files.com/. Then place them in the C:\Windows\SysWOW64 folder only. Neither require registration. After that Civ4 opens without issue.

Thanks all, it seems it was the msvcp71.dll that was the missing link. As soon as I put it in the SysWOW64 folder (didn't register it), the game launced.

Didn't ever get the email notifications on the post for some reason, or I would have tried sooner.
 
Thanks for this thread. I had this error alert today with the Civ4 Vanilla version bought in 2005 and installed on this machine in 2010. I played without a problem as recently as March of this year. Moving both msvcr71.dll and msvcr71.dll from Civ4's BtS subfolder to Windows' SysWOW64 subfolder solved the problem for now (thanks!).

Does anyone know whether there was a recent Windows Update that caused this problem and that might bring it back again?
 
Top Bottom