Win 7 and XP (64 bit) civ 2 MGE and TOT issues (Fix inside!!)

Discussion in 'Civ2 - Technical Support' started by MastermindX, Nov 17, 2006.

  1. paige

    paige Chieftain

    Jan 8, 2011

    The only game I play is Civ II MGE. I've been playing it on a desktop with Windows XP. I've not had any trouble playing it on my desktop. I recently purchased a new HP G-series with Windows 7 installed. I assume it's a home edition of the OS. I can install the game, but cannot play it.

    I read through the complete thread about this problem. I downloaded one of the patches, but I couldn't get it to work. I get error messages. I don't have any idea how to use patches. This is the first time I've had to do this. Could someone please recommend a patch for my set-up and explain, step-by-step, how to use it?

  2. kayalana

    kayalana Chieftain

    Jan 8, 2011
    I need some major help with getting Civilization II to play on my windows xp pro 64 bit computer. When I press autoplay nothing happens and when I try to open the SETUP I get the message ' The image file D:\SETUP.EXE is valid, but for a machine type other than the current machine. ' Can anyone tell me step by step how to get this game to play on my system? Please? Thanks a ton!
  3. Civ II adict

    Civ II adict Chieftain

    Feb 6, 2011
    hi people

    i have a 64 bit windows 7 laptop and am trying to put the original civ II, after reading through this thread i am slightly confused as to what i should do

    each time i insert the disk in the drive and select the auto run option it says:

    "The version of this file is not compatable with the version of windows you are running. Check your computer's system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program and then contact the software publisher."

    I have not yet run any add ons/patches as i am not sure which ones i need, if anyone has any info on this matter it would be greatly appreciated, im sure im not the only one with this problem
  4. chaczar

    chaczar Chieftain

    Nov 24, 2010
    to tell you the truth, it isn't worth the hassle to get Civ II to run on your system.
    What I recommend is Civ IV. It's cheap to buy. It runs just great if you have a decent computer on Win XP 64 pro. It what I'm running. Graphics are terrific. Cheats work as long as you follow the instructions on the thread here....think the code is chipoltle....if you want the cheats to work

    Civ 2 is just fine on an XP 32 bit machine but isn't worth the hassle.
    Amazon has Civ IV cheap and you want THE Complete Edition by 2K games. There's another version out there with a different logo than 2K...don't get that one.
    Plus since Civ 4 plays so well on Win XP 64 bit systems with better graphics....
    why not play the version that works best?

    Make sure and go to Microsoft and download
    the latest Direct X for your system....think it's version 9
    Civ 4 plays just dandy with it.
  5. Jokemaster

    Jokemaster Insert something here

    Nov 15, 2010
    He's trying to install Civ2, not civ4. ^^

    Anyways: IIRC, there is no patch to get the original civ2 (version 2.42... is that what you are trying to install?) to run on a 64bit OS. On a 32bit OS (like mine) no patch is required to run the game, altough I had to activate XP compatibility mode to get all the videos and stuff (I'm running Vista) So if you can find a way to get a dual boot option (one with 32bit and one with 64bit) on your computer, it could work. Not sure how you do that however.
    For MGE and TOT, you can use the patch on this thread.
  6. Catfish

    Catfish Emperor

    Nov 2, 2003
    Wollongong, Australia
  7. Andu Indorin

    Andu Indorin Retired Druid

    Jan 15, 2001
    Colorado Spgs, CO
    "Hello Andu Indorin, it appears that you have not posted on our forums in several weeks. Why not take a few moments to ask a question, help provide a solution, or participate in a discussion in any one of our forums?" ...

    Several weeks ? ? ? ... That's an understatement.

    But if you insist, consider the following as "participation":

    Damn Windows 7. Damn Windows 7 to hell.

    Preliminaries passed. Needless to say, direct attempt of installing Civ2 "vanilla" directly to a Windows 7 is a failure, because Microsoft are basically greedy bastards bent on world domination. However, copied all files from this old, old CD-ROM (that's read-only-memory for those who haven't had a history lesson in obsolete technology) directly to hard drive (... MPS\Civ2 directory).

    NEXT, Downloaded Cedric's five-part MGE patch conversion -- -- and manually copied (i.e., overwrote) those files into the same directory.

    THEN followed the above directions:

    So far, so good.

    Now let's play a game Civ2 on Windows 7 and see what follows. I do hope it works as well as others have noted ...

    UPDATE: ...

    Could not load saved games. Fortunately, from another thread in this tech support section regarding ToT Saved games, a solution was offered:

    SO, for simplicity sake, created a Microprose Software folder in the C:\ directory, and copied the Civ2 directory from Windows 7 "default" Program Files x86 directory to the new folder. Problem solved: saved games now loading.
  8. yopaulie

    yopaulie Chieftain

    Feb 11, 2011
    I need a civ 2 mge patch for windows 7, 64 bit that works for dummies
  9. Brandyn

    Brandyn Chieftain

    Mar 17, 2011
    Hey everyone

    Im sure my problem has been posted on here a million times before but I don't really understand most of what people are saying anywya haha. I can get the game to download from Moderator Action: xxx and the download and set up run perfectly fine. As soon as I try to build a city though, the game shuts down. The only thing that pops up is a message that says windows has encountered a problem with the game and like I said, it just shuts down.

    This is driving me nuts I wanna play this game so bad! I have windows vista and have no idea what the problem is, if you can help me (the most computer ******** person ever) then you can help anyone. Can someone please tell me what I need to do to make this game work?

    Moderator Action: Civ2 is still not freeware. If you want to play this game you need to buy it.
  10. Magic_gorter

    Magic_gorter Moderator Moderator Civ2 GOTM Staff

    Apr 6, 2006
    Amersfoort (Netherlands)
    You need to buy the game instead of downloading it. The copy you downloaded is illegal. You might find a legal copy via amazon. I play civ2 on vista (32 bits) without problems. For vista 64 bit you need to convert it like described in this thread.
  11. Crono

    Crono Chieftain

    Mar 26, 2011
    Lower Norfair
    Thanks a million, Mastermind, this patch worked great for my Civ II MGE (from Civ Chronicles set) on Windows 7 64 Bit Home Premium. After about an hour the music started skipping... but that might go away after restarting. Thanks!

    edit: BTW, I have the game running in compatibility mode for Windows 95 and am running it as an administrator
  12. Mike0Ryan

    Mike0Ryan Chieftain

    Mar 27, 2011

    First off, I'd have been dead in the water without this thread! Thank you! Thank you! Thank you! :goodjob:

    I suppose there aren't that many CIV II diehards out here who are just getting around to installing it on Windows 7 64-bit, but I'll share my experience just the same:

    Step 1: I started from an old "vanilla" version of CIV II that wouldn't even install on my Windows 7 machine. I got around that by installing CIV II to a flash drive plugged into my laptop which is still running Windows XP, and then copied those files into a CIV2 directory on my Windows 7 machine. CIV II would not run; Windows 7 says its an incompatible executable. As described many times earlier, I gather that this is a 16-bit executable that will not run under 64-bit Windows.

    Step 2: I downloaded the five-zipfile MGE patch on this site, unzipped all the files, and copied them over into the CIV2 directory. Oh happy days! CIV II runs! Most everything seems to work (including music and sound effects -- but they are all very, very loud); the opening video doesn't (but who cares!). All indications show it to now be Multi-player Gold (which I understand to be a 32-bit executable). Besides an uber-aggressive AI, the CD now needs to be in the drive.

    Step 3: I downloaded the no-CD crack for MGE from this site. It turned out this also would not run under Windows 7, so I copied it and the (MGE) CIV II executable back over to my laptop. The crack seemed to run correctly and told me that it was successful, but the cracked CIV II executable still called for the CD when put back on the Windows 7 machine. I have no idea why the crack didn't work.

    Step 4: I thought about applying the fix for the aggressive MGE AI, but decided I wasn't really comfortable downloading it from another site. Maybe I'll just have to learn to deal with its pissy nature.

    Step 5: As others have pointed out, CIV II still crashed whenever a pop-up box (e.g. naming a new city) is called. I confirmed that for some reason going through the menu selection rather than through the function keys seems to avoid the problem. Nonetheless, I downloaded MastermindX's patch and ran it after starting CIV II up. The crack worked perfectly.

    I'll add one sidenote about Norton Security (which I'm using because it's free for Comcast internet customers). Norton has added a "Sonar" function that actively compares executables on a PC it's protecting against a database of similar executables reported by other PC's, and is ready to interpret any differences as security threats. I was dumbfounded when "Sonar" popped up to notify me that it had quarantined my (MastermindX-patched) CIV II executable; it seems that the patched executable no longer matched the CIV II executable has been seeing on other PC's. It took me a while to realize I had to be logged in under an adminstrative account in order to restore the patched CIV II executable and put it on the "Sonar" exempt list.

    Once again, thanks to everyone who helped make it possible to get CIV II up and running on Windows 7 64-bit. I'm really happy to be playing it again! For a while there I was thinking I'd have to learn how to play CIV IV (which I've also installed). :lol:

  13. mocthezuma

    mocthezuma Chieftain

    Mar 28, 2011

    I'm new to this forum, but I'm not new to this game.

    I am running this game on Windows 7 Home Premium.

    I have installed the game fine and run the patch. First two executions of the game worked well.

    Then the game started asing for a CD. I downloaded the no cd patch. copied the crack and the civ2.exe file into a temporary folder and ran the crack via DOSBOX and it worked. It did not work when trying to run the patch in the civ2 folder. I then moved the civ2.exe file back into the civ2 folder and now the game starts up again.


    Saving games and loading games does not work.

    The screen blinks, or flashes when I try to do either. After playing fore quite some time, I tried to save the game, but nothing happens. I do have a couple of Autosave files in the civ 2 folder which probably would help me, but the load game option doesn't work. Not from the main menu, not from within a game and not the hotkey. All of which just make the screen blink once and then go back into the game.

    I tried creating a folder in c:\ called Microprose Software and move the civ2 folder in there (which is called \Civilization II Multiplayer Gold Edition) but the problem persists.

    If someone could help me with this I would be very happy as I am so close now to be able to enjoy this game fully again.

    And thank you all for all the effort of getting this baby running on Vista and 7. :D
  14. MastermindX

    MastermindX Chieftain

    Nov 17, 2006
    Try creating a folder civ2 at the root of the directory (or right under program files).

    Civ2 doesn't like long path names.
  15. mocthezuma

    mocthezuma Chieftain

    Mar 28, 2011
    Nope. Tried that. Installed it under C:\Civ2 , updated to 1.3, applied nocd crack, patched with your patch and ran the game as administrator in windows 95 compatibility mode.

    Same thing happens.

    This time none of the video sequences worked. Like the advisors clips and wonders.
  16. Freeed

    Freeed Chieftain

    Jul 24, 2009
    Hi! I have a problem running ToT. I installed it without any problems. I wanted to use the 1.1 patch from this page, but when i run it it says that I need ToT installed. So I found an "extracted" patch which is applied by simply overwriting the needed files. After that, the game starts but crashes everytime after starting a scenario oder normal game. Then I applied Masterminds patch, which told me it was successfull (23 bytes written to file...) but there is no change. It still crashes after starting a game.

    I use Windows 7 Home Premium 64 bit.
  17. civ2

    civ2 Emperor

    Nov 17, 2004

    I totally agree that MS is just plain STUPID or I-don't-know-what!!!
    It's the THIRD game (or similarly) that WON'T run on Windows 7!!!
    1. Spore v1.5 => had to find a LOWER version; spent a lot of time and much more NERVES...
    2. GTA 4 (and some similar) => this time it's the XLIVE problem...
    3. Civ2!!!
    Thanks a LOT for the solution!!!

    The problem is somewhat similar to Vista unable to run DOS games => same logic at least.
    Not that I see ANY logic in the fact though.
    WHY??? Why do the make "obsolete" games really "obsolete"?????

    Oh, btw, I recently bought a newer laptop and (forcibly!) switched from Vista to W7...
    Not sure it was worth it...
    The windows part, I mean. :D
  18. vonmatrices

    vonmatrices Chieftain

    May 9, 2011
    Ok, I think of myself as a pretty smart guy, so here is the situation:

    I just got a laptop with Windows 7 Home Premium. Its running 64 bit.

    With 64 bit, I saw that vanilla CIV2 doesn't work. Boo hoo.

    So, I go out and my local thrift shop had a copy of CIV2 Test of Time sitting there.

    I pick it up, having reviewed this thread before and seeing that it is somewhat possible to get this to work.

    I pop in the CD, and I try to run setup.exe and it doesn't run. I assume due to the 16 bit issue listed previously. No matter - I just copy the CIV2 folder to my desktop.

    I try to run the CIV2.exe in the folder from the Test of Time CD I just bought, and a similar error message appears:

    "The version of this file is not compatible with the version of Windows that you are running. Check your computer's system information ..." Basically telling me I need a 32 or 64 bit version of the program. Fine.

    I download the and extract it. I run the EXE inside the zip archive. It asks me where the civ2.exe file is. I move the CIV2 folder to C:\civ2 for ease of use. I click the "Patch" button and I get the following message:

    Creating file backup

    Backup completed
    Searching for patch location
    ERROR : Patch location not found.

    So, here are now my questions:

    1) What patch location is this program looking for, and how do I satisfy it? This error message is vague as HELL.

    2) I have ToT fresh from the box, and I assume it is version 1.0. Trying to get a ToT 1.1 patch installed didn't work, because I couldn't install the game in the first place. Someone made mention earlier of an "extracted" patch that I could use. My google-fu didn't come up with it. What are my options, and is the 1.1 patch necessary for this?

    3) Am I just s*** out of luck on this one or am I just a moron?

    4 years of study to get my Comp Sci degree and I can't follow simple instructions on a forum. Shame on me.

  19. vonmatrices

    vonmatrices Chieftain

    May 9, 2011
    I don't want to be rude, but if there is an obvious answer I need it soon. I'll be overseas in less than a month here and I may not get to read the answer. Even if it is "Get lost n00b". I'd hope not, though.
  20. theemaster

    theemaster Chieftain

    Apr 28, 2006
    Sorry, even though I'm a "civfanatic" :D I've never played test of time..

    But I just got Civ2:MGE v1.0 working easily and effortlessly on my box.. (I thought you needed a emulator like the windows one or vmware to do it! :p )

    My box is Windows 7 Ultimate SP1 64 bit, Athlon II X4 640 processor 3.0 ghz, 8 Gb of ram ddr3, ati 5570 1 gb etc. etc.

    Here are the steps I did..

    I launched the installer (setup.exe) after it crashed/"was slow" in re-correct settings mode or whatever that Windows7 prompt is..

    When I right clicked it's "compatibility" I found that xp sp2 had been checked.. I also added 256 colors (have no idea if that made a difference)

    It took about 5-10 minutes.. but the installer finally came up and I was able to click next (I had crashed it a few times before.. being impatient)

    And it installed.. to my shock! :D

    But when I launched the game there where 3 problems (it launched and that was great!)

    1. Was the music from the CD was not playing.. I fixed that with this thread.. (as I installed civ2 from a cdrom emulator like this person did.. I burned my civ2 to disc on my only cdrom and walla! I had music..)

    2. Do to it being wishy washy when launching civ2 (sometimes weird windows of blackness) I turned on "compatibility mode" to windows xp sp2 for the civ2 executable.. that seemed to help..

    3. When I went to settle a city.. it immediately crashed.. so I installed MastermindX's patch.. and I can now do that now...

    So I'm going to spend many hours playing now.. if there's any additional issues.. I'll post back.. I'm surprised it all works.. :goodjob:

Share This Page