• Civilization 7 has been announced. For more info please check the forum here .

Won't run under iOS 17.4

UTD still nothing??? I didn’t do the update not aware of this but just because and last night my phone updated by itself (left it on the charger 🤦‍♂️). I submitted a request to Aspyr 4 hours ago and nothing. So I just tried 2k support. Let’s see…
 
Nothing. Meanwhile, still for sale on the App Store but won't run for anyone who purchases or upgrades to the new OS. Other than a note on Aspyr's web site that they are aware of "some users having this problem," there's been no information. "Some?" Seriously? Find me anyone running the latest OS who is able to even launch the game, Look, I get that Aspyr is likely not the biggest company in the world and it may take them longer to fix than most, but we're going on a couple of months unable to play with little to no information on whether they will bother to make it playable again. I hope Firaxis is aware of the problem and maybe can look at brining in some help or a new porting firm.
 
possible all should report it, when having only a few reports it is some still. Raised a bug report also now.
 
Yea! Fixes the start issue for me. Haven't played long enough to see if there are any other issues, but so far looks good.
 
Yes it works for me and apparently now if you link your 2k account to the game it gives Julius Caesar an upgrade. But all my save games are gone.
 
for me one game worked, crashes from long ago are back, but with austo saves it works.
 
Works for me again but cloud saves are still broken. Has anyone gotten them to work since the last update?
 
no, and I have more often crashes in my games, but they are with marathon and largest maps at the limits. Clearly a prahic clitch, which was being fixed before already.
 
Top Bottom