• Civilization 7 has been announced. For more info please check the forum here .

Workers leave old improvments/forests - how to enable


Nov 12, 2005
Unless I'm missing something, these options dont seem to be available anywhere in the game interface. I believe the way to enable them is to open up Assets\Gameplay\XML\GameInfo\Civ5PlayerOptions.xml then change the following to true:



After doing that my workers appeared to have left old improvements and forests alone

Edit: you can also try AutoWorkersDontReplace = 1 in %userprofile%\Documents\My Games\Sid Meier's Civilization 5\UserSettings.ini
AutoWorkersDontReplace = 1 in %userprofile%\Documents\My Games\Sid Meier's Civilization 5\UserSettings.ini should suffice, although I don't see a separate option for forests. For some reason UserSettings.ini is the only of the three/four config files that has no clarifying comments..
thanks, I didnt know about the ini file - have changed that as well now! Automated workers are so ******ed - without this setting they were changing my farms next to rivers/lakes to trading posts, thus removing the +1 food bonus from civil service.
Thanks for this. Hopefully a patch comes out soon sorting out the AI for workers.
is that all i need to do change that ini file? i'm tired of my farm/hammer city's being changed into tradeposts
This is awesome news, thank you. I generally prefer to micro workers anyway but when my empire grows large enough that it becomes a little cumbersome I’ve definitely thought “man I’d be okay with auto’ing this worker if it wouldn’t go tearing up my river farms”.
The ini file change did NOT fix the problem in my games...I will try the other options.
Top Bottom