1. Civ6 is coming out TODAY! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  2. Main site is finally re-opened! We migrated it to a new CMS and gave it a new layout as well.
    Dismiss Notice
  3. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice
  4. Downloads database has been migrated and re-opened! Check it out and post in Site Feedback if any issue. We have done URL re-write so that old links will continue to work.
    Dismiss Notice
  5. A new Civ6 theme forum style is now available and it's made the default forum style! Check it out and comment here.
    Dismiss Notice
  6. We have successfully migrated the forum from vBulletin to Xenforo! Please take a look around and report any issue you see in Site Feedback.
    Dismiss Notice

crash back to desktop after flashscreen

Discussion in 'Civ3 - Technical Support' started by fortezero, Nov 2, 2001.

  1. fortezero

    fortezero New Member

    Nov 2, 2001
    alright guys, here's the deal. hehe.. i really want to play this game, see.. but stuff keeps stopping me!

    700mhz athlon
    256 megs of ram
    40 gig hdd
    sb live x-gamer
    hercules guillemot geforce 2 gts pro 32 mb

    i have the 21.83 detonator for the geforce and the newest sblive driver i can find.. thing is, i load the game, it loads the splash screen, loads for a few seconds, and then i get dumped back to desktop with nothing left running in the system's resources. gr! argh! if anyone has any ideas, i'm all open for them!
  2. Farmer

    Farmer New Member

    Oct 31, 2001
    I had the same problem. I fixed it by changing the screen resolution to 1024X768.

    The game ran FLAWLESSLY after that. Well I had to get my sound working, but that was my own stupid fault. Well actually it was Creative's fault for not updating my system settings. Anyhow, hope this helps you out.

    I got lucky, I didn't actually think my monitor would support 1024X768 res!

    - Dave
  3. Serg

    Serg Engineer

    Aug 22, 2001
    St.Petersburg, Russia
    Try press <Enter> or <Space> at once after launch program. This passes movie and go to Game.
  4. FrankyR

    FrankyR New Member

    Nov 6, 2001
    I have the same problem, but nothing I do will work. I have the computer set to the proper res and colour depth, and I hit space and enter as soon as the splash screen comes up, but nothing helps! I also quitted everything.

    667mhz celeron
    64 mb ram
    1g empty hd space
    Intel 810e graphics card
  5. pwarnk

    pwarnk New Member

    Oct 27, 2001
    try the 1024x768 @70 driver this may fix your problem

Share This Page