1. Dismiss Notice
  2. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  3. Main site is finally re-opened! We migrated it to a new CMS and gave it a new layout as well.
    Dismiss Notice
  4. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice
  5. Downloads database has been migrated and re-opened! Check it out and post in Site Feedback if any issue. We have done URL re-write so that old links will continue to work.
    Dismiss Notice
  6. A new Civ6 theme forum style is now available and it's made the default forum style! Check it out and comment here.
    Dismiss Notice
  7. We have successfully migrated the forum from vBulletin to Xenforo! Please take a look around and report any issue you see in Site Feedback.
    Dismiss Notice

Low FPS. And strange shapes in the game.

Discussion in 'Civ4 - Technical Support' started by Vergrix, Dec 25, 2005.

  1. Vergrix

    Vergrix Chieftain

    Dec 25, 2005
    Hello I get strange lines and shapes while I'm palying the game. Also how can I improve my FPS Rate?

    Dx Diag Results

    System Information
    Operating System: Windows XP Home Edition (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_gdr.050301-1519)
    BIOS: Default System BIOS
    Processor: Intel(R) Pentium(R) 4 CPU 1700MHz
    Memory: 512MB RAM
    Page File: 213MB used, 1036MB available
    DirectX Version: DirectX 9.0c (4.09.0000.0904)
    DX Setup Parameters: Not found
    DxDiag Version: 5.03.2600.2180 32bit Unicode

    Display Devices
    Card name: RADEON 9200 SERIES
    Manufacturer: ATI Technologies Inc.
    Chip type: RADEON 9200 SE AGP (0x5964)
    DAC type: Internal DAC(400MHz)
    Display Memory: 128.0 MB
    Current Mode: 1024 x 768 (32 bit) (60Hz)
    Monitor: COMPAQ 171FS
    Monitor Max Res: 1024,768
    Driver Name: ati2dvag.dll
    Driver Version: 6.14.0010.6490 (English)
    DDI Version: 9 (or higher)
    Driver Attributes: Final Retail
    Driver Date/Size: 10/26/2004 20:35:58, 214528 bytes

    My agp speed is 8x and im using direct3d, fastwrite is off ( what is fastwrite ) I want to try using opengl. maybe that one will work better than direct3. how do i use opengl?

    Is my pc meets the requirements of playing Civ 4? I have low fps and I wish to improve my fps.Thanks for all your help.
  2. iron_monkey

    iron_monkey Chieftain

    Dec 18, 2005
    Swindon ('til I die?), England
    In my opinion your PC should be able to run the game fine. I'm guessing that seeing as this is your first post and it's Christmas day you might have got the game today so my first suggestion will be to patch it. You may have already done this but also maybe not. The game initially had a lot of problems with memory leaks and even working at all on some ATI card/driver combos so there's a good chance that patching it will solve your problems.

    Check here http://www.civfanatics.com/civ4/patch/ for some mirrors that contain the patch.

Share This Page