1. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  2. Main site is finally re-opened! We migrated it to a new CMS and gave it a new layout as well.
    Dismiss Notice
  3. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice
  4. Downloads database has been migrated and re-opened! Check it out and post in Site Feedback if any issue. We have done URL re-write so that old links will continue to work.
    Dismiss Notice
  5. A new Civ6 theme forum style is now available and it's made the default forum style! Check it out and comment here.
    Dismiss Notice
  6. We have successfully migrated the forum from vBulletin to Xenforo! Please take a look around and report any issue you see in Site Feedback.
    Dismiss Notice

Won't open at all.

Discussion in 'Civ4 - Technical Support' started by bonhomie, May 7, 2010.

  1. bonhomie

    bonhomie Chieftain

    May 7, 2010
    A while back I bought the direct2drive version of Civ4, but never got around to installing it. I finally did so the other night, and was perturbed to discover that it simply refused to open.

    I tried turning off my firewall, reinstalling multiple times, anything I could think of, but it refuses to work at all. I don't even get any kind of loading screen, I just see the Windows hourglass pop up for a moment and then nothing.

    I'm using XP, and though I don't have the greatest rig it should certainly be able to run this game. So what should I do?

    Any help would be greatly appreciated.

Share This Page