Advertisement
Civilization Fanatics' Center

Go Back   Civilization Fanatics' Forums > CIVILIZATION IV > Civ4 - Creation & Customization > Civ4 - Project & Mod Development > Inactive Projects > Civ4 - Song of the Moon

Notices

Reply
 
Thread Tools
Old Aug 15, 2007, 12:09 PM   #221
matthewv
Emperor
 
matthewv's Avatar
 
Join Date: Aug 2004
Location: BC, Canada
Posts: 1,007
xmls I think are fully loading now so the xml log can no longer be used to determine where its crashing. I am out of ideas ATM.
__________________
Playing Civ V and loving it
matthewv is offline   Reply With Quote
Old Aug 15, 2007, 12:10 PM   #222
woodelf
Bard
 
woodelf's Avatar
 
Join Date: Jun 2003
Location: Gallery
Posts: 15,036
What comes next? Opening Slideshow, music, ????
woodelf is offline   Reply With Quote
Old Aug 15, 2007, 12:12 PM   #223
woodelf
Bard
 
woodelf's Avatar
 
Join Date: Jun 2003
Location: Gallery
Posts: 15,036
Did Geo post the Audio XMl anywhere? Or can we use the stuff from Vanilla SotM? I have a soundtrack folder and am wondering if it's causing an issue without having XML telling it pick Moon Music
woodelf is offline   Reply With Quote
Old Aug 15, 2007, 12:14 PM   #224
matthewv
Emperor
 
matthewv's Avatar
 
Join Date: Aug 2004
Location: BC, Canada
Posts: 1,007
It could be sound but I have no experience with sound in Civ4
__________________
Playing Civ V and loving it
matthewv is offline   Reply With Quote
Old Aug 15, 2007, 12:19 PM   #225
woodelf
Bard
 
woodelf's Avatar
 
Join Date: Jun 2003
Location: Gallery
Posts: 15,036
Here's the last file in the log, small file.

Does that tell you anything as it loads the engine?
Attached Files
File Type: zip init.zip (569 Bytes, 17 views)
woodelf is offline   Reply With Quote
Old Aug 15, 2007, 12:29 PM   #226
matthewv
Emperor
 
matthewv's Avatar
 
Join Date: Aug 2004
Location: BC, Canada
Posts: 1,007
Quote:
Originally Posted by woodelf View Post
Here's the last file in the log, small file.

Does that tell you anything as it loads the engine?
Maybe, Now what does that log look like when loading just BtS whitout any mod?
__________________
Playing Civ V and loving it
matthewv is offline   Reply With Quote
Old Aug 15, 2007, 12:40 PM   #227
woodelf
Bard
 
woodelf's Avatar
 
Join Date: Jun 2003
Location: Gallery
Posts: 15,036
Here's a regular BtS init
Attached Files
File Type: zip init-BtS.zip (701 Bytes, 20 views)
woodelf is offline   Reply With Quote
Old Aug 15, 2007, 12:52 PM   #228
matthewv
Emperor
 
matthewv's Avatar
 
Join Date: Aug 2004
Location: BC, Canada
Posts: 1,007
Hmm, its eitheir Font or MenuManager that is causing the CTD. I am stumped ATM and it is hard for me to pinpoint the bug further without access to civ4.
__________________
Playing Civ V and loving it
matthewv is offline   Reply With Quote
Old Aug 15, 2007, 12:53 PM   #229
woodelf
Bard
 
woodelf's Avatar
 
Join Date: Jun 2003
Location: Gallery
Posts: 15,036
Quote:
Originally Posted by matthewv View Post
Hmm, its eitheir Font or MenuManager that is causing the CTD. I am stumped ATM and it is hard for me to pinpoint the bug further without access to civ4.
Did we change either of those?
woodelf is offline   Reply With Quote
Old Aug 15, 2007, 12:54 PM   #230
matthewv
Emperor
 
matthewv's Avatar
 
Join Date: Aug 2004
Location: BC, Canada
Posts: 1,007
BTW what did we change in CIV4ColorVals.xml?
__________________
Playing Civ V and loving it
matthewv is offline   Reply With Quote
Old Aug 15, 2007, 12:55 PM   #231
GeoModder
Deity
 
GeoModder's Avatar
 
Join Date: Nov 2005
Posts: 7,179
Images: 1
I didn't upload sound xml yet. Just check under your Assets/XML/audio folders to see if there is any file inthere. There is none here, I only tested audio in a fake mod. (and got it to work )
GeoModder is offline   Reply With Quote
Old Aug 15, 2007, 01:02 PM   #232
woodelf
Bard
 
woodelf's Avatar
 
Join Date: Jun 2003
Location: Gallery
Posts: 15,036
Quote:
Originally Posted by matthewv View Post
BTW what did we change in CIV4ColorVals.xml?
Probably nothing.
woodelf is offline   Reply With Quote
Old Aug 15, 2007, 01:03 PM   #233
woodelf
Bard
 
woodelf's Avatar
 
Join Date: Jun 2003
Location: Gallery
Posts: 15,036
Quote:
Originally Posted by GeoModder View Post
I didn't upload sound xml yet. Just check under your Assets/XML/audio folders to see if there is any file inthere. There is none here, I only tested audio in a fake mod. (and got it to work )
I put the Vanilla XML files into this conversion. Is that the files you used?
woodelf is offline   Reply With Quote
Old Aug 15, 2007, 01:36 PM   #234
woodelf
Bard
 
woodelf's Avatar
 
Join Date: Jun 2003
Location: Gallery
Posts: 15,036
3 last XML errors in Civ4ForceControlInfos. They must not be a big deal since the game progresses on before crashing. The trouble is that there are no references in that file to the errors that appear.
woodelf is offline   Reply With Quote
Old Aug 15, 2007, 01:51 PM   #235
matthewv
Emperor
 
matthewv's Avatar
 
Join Date: Aug 2004
Location: BC, Canada
Posts: 1,007
Quote:
Originally Posted by woodelf View Post
3 last XML errors in Civ4ForceControlInfos. They must not be a big deal since the game progresses on before crashing. The trouble is that there are no references in that file to the errors that appear.
I have seen things like that before. The error is not really in Civ4ForceControlInfos but another xml. the reason it is reported wrong is due to bugs in SDK.
__________________
Playing Civ V and loving it
matthewv is offline   Reply With Quote
Old Aug 15, 2007, 02:07 PM   #236
GeoModder
Deity
 
GeoModder's Avatar
 
Join Date: Nov 2005
Posts: 7,179
Images: 1
Quote:
Originally Posted by woodelf View Post
I put the Vanilla XML files into this conversion. Is that the files you used?
I used the SotM files I adjusted for the MP3's I sent you a month or two ago.
They won't work in BtS, but they won't crash either since I was able to load my fake mod with wrong references in it.
GeoModder is offline   Reply With Quote
Old Aug 15, 2007, 02:31 PM   #237
woodelf
Bard
 
woodelf's Avatar
 
Join Date: Jun 2003
Location: Gallery
Posts: 15,036
I'm officially stumped and tired.

I hope we narrowed it down enough for you to hammer it home matt.
woodelf is offline   Reply With Quote
Old Aug 15, 2007, 02:48 PM   #238
matthewv
Emperor
 
matthewv's Avatar
 
Join Date: Aug 2004
Location: BC, Canada
Posts: 1,007
Quote:
Originally Posted by woodelf View Post
I'm officially stumped and tired.

I hope we narrowed it down enough for you to hammer it home matt.
Thanks for all you've done. Hopefully I can get her purring tonight.
__________________
Playing Civ V and loving it
matthewv is offline   Reply With Quote
Old Aug 16, 2007, 12:40 AM   #239
matthewv
Emperor
 
matthewv's Avatar
 
Join Date: Aug 2004
Location: BC, Canada
Posts: 1,007
Okay, this bug is proving to be very painful. I have exhausted almost all the debugging methods I know of except trying to systematically isolate the bug, which is proving to be very nasty. In the process of trying to isolate the bug I am having problems with game crashing before the bug we want to isolate occurs. This makes things very difficult.

I am not completely out of options but all remain ways I know of to isolate the bug can take several days and many long boring hours. I may have the time to isolate it before next week but I make no promises, especially since it is very tedious work and can be hard to find the motivation to to it.

I don't know if you will understand what I just said, but the short answer is that things are going nowhere fast.

If you have any Ideas I managed to Isolate the bug to one of the xmls in the following folders:
Units
Techs
Buildings
Civilizations
Art
__________________
Playing Civ V and loving it
matthewv is offline   Reply With Quote
Old Aug 16, 2007, 04:11 AM   #240
woodelf
Bard
 
woodelf's Avatar
 
Join Date: Jun 2003
Location: Gallery
Posts: 15,036
Damn. I don't have as much time as normal in the next few days, but when I do I can look at redoing some of those XMLs with limited entries. We don't need a lot of what's in there so there's no sense completely doing any XML file from scratch until we find which file.
woodelf is offline   Reply With Quote
Reply

Bookmarks

Go Back Civilization Fanatics' Forums > CIVILIZATION IV > Civ4 - Creation & Customization > Civ4 - Project & Mod Development > Inactive Projects > Civ4 - Song of the Moon > [BtS] - Updates and progress

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Advertisement

All times are GMT -6. The time now is 02:44 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
This site is copyright Civilization Fanatics' Center.
Support CFC: Amazon.com | Amazon UK | Amazon DE | Amazon CA | Amazon FR