Mod worked on the Devtool, but now nothing works after upload on steam


Aug 21, 2020
Hello, after working a bit for it, I had a perfectly working mod and I uploaded it on steam. I then tried the mod from the steam download and it crashed. I then re-tried my dev version and it worked, so I tried to re-launch my game. Now both my mods aren't working and I really don't know what broke.
Can't upload the here, but if suspect I've might done something wrong there, if anyone could explain me step by step what I must do would to config it would be appreciated.


  • GameDefines.xml
    1.3 KB · Views: 17
so, after trying and trying, I finally managed to make the mod work again... By recreating
I have literally did nothing different, I created a new mod file, put my ancient work there, re-build it, and it was working...
I frankly hate Civ VI dev tool by how random it's make my mods work.
so anyway, case close, it's working! If anyone happended to have the same problem as me, just create all-together a new project on civ dev tool, put yours action and then build.
Top Bottom