• Civilization 7 has been announced. For more info please check the forum here .

Modding questions, Linux OS


Jan 27, 2015
Hello everyone! I am new here, so please forigve any mistakes I make as I learn the ropes. I've been playing civilization since civ 4, and I have all of civ 4's expansion packs. While I can't play civ 4 anymore (because I now use the Linux OS), I do play civ 5 with Gods and kings, and civ BE in native linux! :)

That said, I have several questions regarding mods for the Linux OS. They are as follows:

-I installed Boogieman's AI mod from the steam workshop. I played it once, then it never worked again after that. The game always crashes as soon as I press the start button, when using that mod. So, I'm wondering how I would go about uninstalling that mod and maybe re-installing it manually, on the Linux OS? I tried digging through ~/.local/share/steam/<rest of path to civ BE files> and related directories, but I couldnt get anything working.

-How can one go about making mods for civilization beyond earth on the Linux OS? I've modded games in the past, and I have some ideas that I think could work with civ BE. Just not sure how to go about doing it on the Linux OS, or what tools for modding Civ BE I'd need.

My exact distribution of Linux and hardware specifications are as follows: Linux Mint 17 with XFCE desktop. Running kernel 3.13.0-24-generic. Hardware is an AMD A4-4300M APU with Radeon HD 7420G graphics. I'm using the proprietary driver for the APU from the AMD website.

If you need any additional info, please ask. All help appreciated!
Alright, so some progress has been made. Here is what I have done to try and get mods working:

-Browse to /home/johnbobsmith/.local/share/aspyr-media/Sid Meier's Civilization Beyond Earth/MODS/ (note that its aspyr-media and NOT just aspyr, that stumped me good for a while!)
-use ciopfs utility to create a cas-insensitive filesystem in the MODS directory.
-put the downloaded mod files in that directory

They now show up manually when I put them there, but it still crashes upon load?? I don't understand why it worked ONCE from the steam workshop, and never again. It always crashes... :(

My best guess is that some sort of cache or something is overiding what the mod says to do. So I will dig around some more, and figure out what could be causing this. Everything else works flawlessly, except for Boogieman's AI mod, which I really want.
I haven't had any luck at all getting mods to work in the native Linux build. Some claim to have gotten it working here, but I tried what was mentioned there with no luck: https://steamcommunity.com/app/65980/discussions/0/626329820966171725/

The Windows version does seem to run on Linux using Proton 8 or higher. Sometimes it will crash before the mod selection screen, but when that happens I delete everything in ~/.steam/steam/steamapps/compatdata/65980/pfx/drive_c/users/steamuser/Documents/My Games/Sid Meier's Civilization Beyond Earth/MODS/ and the game will reinstall the mods and seems to work.

Also Civ 4 works great with Proton on Linux :)
Top Bottom