Reinstall after Purchase of NFP : Cannot create new game

vorlon_mi

Emperor
Joined
Oct 21, 2004
Messages
1,202
Location
Chelsea, MI
I purchased the game in Aug 2020, including R&F and GS, and successfully ran it on my laptop. Played for a while, logged some Steam achievements. I uninstalled to save some space until today. I went to the Steam store, bought the Anthology bundle so that I can get the Leader Pass content that is coming.

The game starts, I go to single player and ask for the simplest, auto-generated game "Play Now". NO MODS, other than what Steam gives me for what I've paid for.
"Error Starting the Game One or more mods failed to load content"

Yes, I have used Steam to verify the 30,000 files. Yes, I have uninstalled and reinstalled again.

What to try next? Which log files should I look at to find the error?
 

Laurana Kanan

Don’t underestimate who I am.
Moderator
Joined
Apr 10, 2014
Messages
3,753
Location
Near the Greatest Snow on Earth
You can look at the Database.log file @ "...\Documents\My Games\Sid Meier's Civilization VI\Logs\Database.log" and look for anywhere that says ERROR.

My general advice is to first verify the integrity of your game files through Steam if you've not already done so.

If that doesn't work, next try deleting the Mods.sqlite file @ "...\Documents\My Games\Sid Meier's Civilization VI\Mods.sqlite" and the three debug files in "...\Documents\My Games\Sid Meier's Civilization VI\Cache".

If that still doesn't work, try uninstalling the game making sure to delete any leftover files/folders in "...\Documents\My Games\Sid Meier's Civilization VI" and "...\Steam\steamapps\common\Sid Meier's Civilization VI", and then do a fresh install.

And, finally if none of that works you can submit a support ticket to 2K/FXS here. They'll likely ask you to submit information like the diagdx, GraphicsOptions, and logs that can be found by following the instructions here.
 

vorlon_mi

Emperor
Joined
Oct 21, 2004
Messages
1,202
Location
Chelsea, MI
Update: I did another uninstall and renamed the folder in "My Games" for Civ VI to "OLD_Sid Meier's Civilization VI". In another thread (though I can't find it right now), I had read that the automatic mirror/backup of Documents -> My Games to my OneDrive Personal could mess up something in the way Civ VI writes its status files.

When I reinstalled again from Steam, I told it to install in a "Create a New Library on D:" using my larger HDD. This seems to work! I can now launch the game, create a new game, and even select Abe Lincoln as my leader. So far, so good.
 
Top Bottom