[BNW] Run-Time Error Fixed


Hall of Fame Staff
GOTM Staff
Oct 13, 2015
The Boonies of Central Michigan
(This is everything I’ve recently learned about this problem – getting a solution all in one place.)

For about a month I have not been able to load a Civ V save-file. “Single User” “Load” would cause a Run-time Error and would terminate Civ. We tried everything (my son, @pidgey_op, is an IT professional), but with very little success. Changed the graphics card, re-installed Civ (to both C:\ and E:\), re-installed Steam, set Steam to offline, and finally even re-installed Windows. Nothin’.

Searching the internet for “Run-time error” returned a lot of threads (from multiple forums) about corrupt Steam cloud-saves. I travel for work, and had saved any number of cloud-files. A couple of years ago @pidgey_op built me a Civ computer, and in setting it up he had disabled the Steam cloud, as he was convinced it was not stable. But while most of the threads I found stated the problem well enough, none of them led to a fix, at least not one that worked for me.

I finally found a March 2012 thread on 2K. I tried this procedure several times (I know – insanity…) with two notable observations: First, I never had the “Cloud Sync Confilct” that it references; second, it did fix something, because I could load Civ saves when Steam was offline. Here is my updated version (I think there are some Steam-setting differences since 2012) of the procedure found on 2K:

Open Steam, go to Steam--->Setting--->Cloud
Untick "Enable Steam Cloud sync…"
Then Steam--->Go offline...
Open your Steam userdata folder (in my case C:\Program Files (x86)\Steam\userdata)
Click on the numbered folder (your Steam ID)
Open folder "8930" (Civ V app ID)
Delete everything inside (These are your Steam cloud-saves for Civ V)
Launch Civ V (Steam is still offline)
Start a game
Play 2 turns
Save the game in Steam cloud (BUT SEE BELOW)
Exit Civ
Exit Steam
Go to the Civ App ID folder again
Delete remotecache.vdf
Start Steam
Steam--->Go online...
Tick "Enable Steam Cloud sync" (Steam--->Setting--->Cloud)
Start Civ
A Cloud Sync Conflict dialog should appear (BUT SEE BELOW)
Select "Upload to the Steam Cloud"
The game should then start, and you should be able to load save files.

This procedure apparently worked for 2K user Decsus, but it didn’t work for me. Until… I SAVED A CLOUD-FILE IN ALL 10 SLOTS! This procedure’s “fix” is to overwrite a corrupt file. Knowing that I had several cloud-saves, it occurred to me that [save file + delete folder] might overwrite only one file’s worth of the cloud, and therefore might not get to the actual corruption. By saving into all 10 slots, I should be guaranteed to overwrite the corruption. And, FINALLY, that worked. (But I never have gotten the “Cloud Sync Conflict” dialog; this might simply be that Steam now handles it differently than in 2012).

One other thing - I also uninstalled Civ from my work laptop. I did this before I arrived at the complete fix, and it didn't help at the time I did it (or at least I don't know if it helped). But knowing that it certainly loaded and saved to the cloud, it seems very likely that it could have been part of the problem. Based on this experience, I would simplify to a single installation prior to going through this procedure.

My guess is that - once you have a Steam cloud-save (you can choose any of the 10 slots), that file is ALWAYS going to exist in the cloud. In other words, I could right now delete the folder in my userdata, but I am not aware of any method to delete those files in the cloud. So, I anticipate that someday a lightning storm will once again strike the cloud, corrupt one of my files (and maybe one of yours!), and we’ll have to do this again.
Last edited:
Well, I have to say this is definitely an interesting fix to this problem. Unfortunately it does not seem to have fixed my inability to load a modded save file. I actually posted a thread on civfanatics and on the steam page looking for help.

Yeah, that is the same error message. I rarely use mods (and wasn't using any during my Great Tribulation), so can't contribute anything there.

Are you able to load unmodded saves?
Yeah, that is the same error message. I rarely use mods (and wasn't using any during my Great Tribulation), so can't contribute anything there.

Are you able to load unmodded saves?

Yeah I can load unmodded saves. I actually (just a couple days ago) found out that my problem was due to conflicting mods. I believe it was the Civilization IV Diplomatic Features that was conflicting with my other mods (https://steamcommunity.com/sharedfiles/filedetails/?id=1471046879).
Top Bottom