Civ causing my computer to involuntarily shut down


Sep 6, 2007

First let me start out by saying that I've searched the forums for a solution to my problem. There seem to be a few similar issues, but the resolution that has been come to either doesn't apply to me or doesn't solve my problem. If I'm a completely daft idiot and have missed the obvious, I apologize.

I've been playing Civ IV since the day it came out. I've never had any problems with the original version, with any of its patches, or with the Warlords add-on. I've literally spent hundreds of hours playing this wonderful game without issue. After a 6 month break, I decided to start playing again once the Beyond the Sword add-on was released. I've updated all versions of the games to all of the latest patches listed on the Civfanatics downloads page.

Since I started playing the recent add-on, I've had the problem where my computer will shut down randomly every couple of minutes of game time. I've had times where I could play 30 or 40 turns before it shut down. Or sometimes I've had it shut down within 4 or 5 turns. Essentially what happens is the game closes without my aid, and a second later my comptuer goes into shut down mode. It then turns off completely. I'm not sure why this is happening, as it's never been a problem before. Unfortunately, not only is it happening with the BtS add-on, but it's also happening when I load up the Warlords game. As I said before, I had previously never seen this happen with Warlords after many hours of play, so I'm thinking it must be a recent patch that is causing my problems.

I've included a zipped folder with both the dxdiag text and MSinfo text. Please help me out in any way that you can.

Thanks for any assistance you may be able to give me.

As time marches on the game gets slower and slower then crashes. Reboot and maybe get anywhere from 5 - 20 turns and crash. I tend to play larger maps at marathon speed if that makes a difference. I'm at work so I don't have the zip file but I've been going through some threads also and this is exactly the problem I'm dealing with. Best game I've ever played but I'd like to finish a match.
I had the same issue with multiple different games (Civ, Madden 08, World of Warcraft).

After a month of trying many different solutions including 3 full system reinstalls and a new video card I stumbled upon a solution.

I had a problem with my RAM speed. I have 4 gigs of DDR 2 667 in my system, I went into my BIOS and made the computer read my RAM as DDR 2 533, this fixed my problem immediately. Normally your BIOS is set to AUTO when detecting the RAM, by changing it to a lower setting then what I had I managed to stabilize my system. No noticeable difference in performance by doing this.

Not sure if this will fix your problem but it did work for me.

Good Luck!
Does your computer restart or just shut down? because mine has restarted and gone to black screen with big chunky writing but it normally doesn't when I restart or turn on my computer... Doesn't happen very often... tells me when to eat :D
I tried the Ram trick and that didn't work. I tried the unofficial patch which sped things up a bit in between turns but I still crashed every few turns. I get a black screen but i have to shut down manually. Even though I have a 3 gig P4 with 2 1/2g of ram (not the latest I know but still able to run Half Life 2 without any burps). I have a new nvidia card on the way so I guess I'll wait for that and the new patch.
I'm trying not to complain, I know the problems will be fixed. I'm a 30+ year gamer and Civ is the best series of games I've ever played. Thanks for the help.
If it helps anyone I did get the game to work. I picked up a GeForce 7800 GS and it works fine now.
Top Bottom