1. We have added a Gift Upgrades feature that allows you to gift an account upgrade to another member, just in time for the holiday season. You can see the gift option when going to the Account Upgrades screen, or on any user profile screen.
    Dismiss Notice

Civ windows version in windows 10

Discussion in 'Civ1 - General Discussions' started by MuuCow, Jun 10, 2016.

  1. MuuCow

    MuuCow Chieftain

    Joined:
    Jun 10, 2016
    Messages:
    2
    hi all civ gamers

    ive been trying to install and play the old civ 1 windows version on win 10.
    but i cant get it to install i run a 64 bit win 10 ,i tryed the compadability option build in but it diddent work , i tried running it as admin ,no luck there eather.

    I kinda lost of wath to du ,thats why im asking here ,and hoping somone can help me.

    Thx
     
  2. Verrucosus

    Verrucosus Warlord

    Joined:
    Mar 25, 2002
    Messages:
    175
    This is tricky. You will need a virtual operating system to get it to run on a 64 bit machine.

    This is what I did:
    1) install DOSBox - http://www.dosbox.com/
    2) install Windows 3.1 inside DOSBox - for instructions see http://www.vogons.org/viewtopic.php?t=9405
    3) install Civ 1 Windows Version under Windows 3.1 inside DOSBox

    Step 2) is really tricky and I only tried it because I still had my old Windows 3.1 floppies.

    Honestly, it's probably easier to get the DOS version of Civ1 than to find Windows 3.1 and set it up inside DOSBox. I also find the DOS version prettier, but that's of course a matter of taste.

    Good luck!
     
  3. MuuCow

    MuuCow Chieftain

    Joined:
    Jun 10, 2016
    Messages:
    2
    i got the old dos version of civ to work with dosbox that was simple enofh. I took a look at the win 3.1 install it looks quite involved ,so i was thinking of instlling winxp 32bit on a nother drive and installing it there. then i can also play other old games as well there :)
     
  4. Oliviciv

    Oliviciv Chieftain

    Joined:
    Dec 25, 2019
    Messages:
    1
    Hi i just bought my first W10 PC, and i'm testing all the games that i used to play on XP.
    Just tried Civwin, and i got multiple errors (path does not exist, or your system cannot execute this software)
    I assumed that this was related to the 16bit nature of the exe.
    Searched a bit on Bing, found this thread, then others...
    Seems there is a 16bit layer for 64bits system that enables them to run 16bit sofware like Civwin.
    Here : Otvdm/winevdm (columbia.edu)
    Install OTVDM, then use otvdmw.exe to open civ.exe... It works !
     

Share This Page