Direct IP problem


Sep 14, 2007

First of all - welcome ! I used to play civ1 and civ2 many years ago. Now I tried to refresh the memories (very good ones) and play Civ4 with my friends. BUT...

Game for 2 players works fine, but when I tried to host a game for 3 players (DIRECT IP).... it didn't work - only 1 player can connect to host and it is always the first one who tried.

I found in some "readme":

Firewalls and Network Address Translation (NAT) present problems for multiplayer games. A new interface for both routers and operating systems called Universal Plug and Play (UPnP) greatly ameliorates these problems. If you have a UPnP operating system (Windows ME or Windows XP) and a UPnP router, you "should" be able to join any public game. If you are not UPnP compliant, you must be the first player to join the game, and no other non-UPnP players will be able to join after you. Make sure UPnP services are enabled on your router. Some current routers (Microsoft for example) always enable UPnP. Others (LinkSys for example) offer UPnP services, but disable it by default.

But all the players have windows xp.

[H] connected to internet via DSL modem
Firewalls - all switched off ( for this test )

HOST[H] <-----wireless (local network) ----- client 1 [C1]
client 2

Configurations which work: 1) [H]<-[C1] 2) [H]<-[C2]
Configuration which does not work: [C2]->[H]<-[C1]

Any ideas?

Thank You in advance for ANY help :)
I have a similair problem. But i am unable to connect to anyone full stop. It just shows the message "host server has timed out" can anybody help us?
I also have a problem with mp. It says the error: network socket encountered an error and disconnected
It is a ports problem... You cant have the server and a client on different machines on the same LAN without specifying a different port for the LAN client. We had the same issue...

I can't remember where to set the port, or which port to use... Let me check.
I can play with friends in Lan using Direct IP connect...but...when we try to connect each one from our homes it does not work....Anyone help please...
Seems that there is no solution for this problem. They screwed up the direct ip play... it works only for 2 players without problems. For more, You have to be really lucky. Apparently I'am not :/
I managed to make it work after a few days of trying.

Here is what you have to do to make direct Ip play..for anyone that might be interested.

Simple stuff:

You need to open port UDP 2056
You need to call your ISP tell them you want to open this port and follow their instructions

Complicated stuff

If you connect to the internet via a router then you need to change the TCP/IP settings of your LAN connection, before opening the port.

The settings at the TCP/IP connection properties must be entered mannually and not have the obtain ip address automatically checked. As every ISP has different DNS server values, you need to call technical support and ask them what values to put there.

Finnaly when you are in the router page, you go to port forwarding page and create an exemption rule for port UDP 2056. You need to make sure that the exemption is made for the ip the client (your computer) has and not for the router ip (For example your router Ip might be and the PC ip on the LAn could be, so the exeption rule in port forwarding should be for
Some advanced routers (like mine) have extra options that you need to check, ask technical support what to put there.

Additionally!!! If you manage to make it work, start your first game and get an OSS error as the game starts, then this can be fixed by creating a new game and turning random events off (that is 3.13)!!!

Good luck!!
Thank you Indiansmoke!

Just opening up port 2056 on my router did the trick for me, and I was able to host a direct IP game for my civ buddies to connect into.

I didn't need to contact my ISP though, just used the public IP address assigned to me on the day. (Can check this by logging into the router or browsing to a site like

Thanks again!
Recently I've been trying Civ IV multiplayer over LAN with a friend, LAN games didn't work so we tried direct IP and it worked with no problems at all. Today however a couple of other people on our LAN have bought Civ IV and have tried to play with us. However after one person has joined no one else can, at all. After connecting to the host the game tries to conenct to 'established peer x' which will always fail and it'll just trot out something about firewalls, this is the same no matter who hosts and who connects, whether firewalls are all off, all on or a combination, and eveyone has the exception enabled for both Civ IV itself and port UDP 2056.

Is there anything else we can try or is the game just complete crap in this aspect?

Also, we all run Civ IV v1.7.4
You could always try opening up some of the other ports listed in this thread.

Not sure if it'll help but may be worth a try.

I was able to get a 3-way direct-IP connection game working just by opening up port 2056, but that was with BtS (v3.13) which may or may not account for the difference...

Good luck!
Top Bottom