1. We have added the ability to collapse/expand forum categories and widgets on forum home.
    Dismiss Notice
  2. Photobucket has changed its policy concerning hotlinking images and now requires an account with a $399.00 annual fee to allow hotlink. More information is available at: this link.
    Dismiss Notice
  3. All Civ avatars are brought back and available for selection in the Avatar Gallery! There are 945 avatars total.
    Dismiss Notice
  4. To make the site more secure, we have installed SSL certificates and enabled HTTPS for both the main site and forums.
    Dismiss Notice
  5. Civ6 is released! Order now! (Amazon US | Amazon UK | Amazon CA | Amazon DE | Amazon FR)
    Dismiss Notice
  6. Dismiss Notice
  7. Forum account upgrades are available for ad-free browsing.
    Dismiss Notice

Installation does not install all files?

Discussion in 'Civ4 - Technical Support' started by Nadir, Oct 27, 2005.

  1. Nadir

    Nadir Chieftain

    Oct 27, 2005

    Just installed Civ4. It wont start however, but not due to the error everyone else seems to have. Just to see if it did any difference i decided to try messing around with the ini file. And then I noticed that there were no ini file. I have tried reinstalling the game a couple of times now, but the ini file is nowhere to be found, not in the My Games folder or in the game folder. Not anywhere on the HD for that matter. All the links in the game directory for different folders supposed to be placed in My Documents\My Games are invalid.

    Now, i have my suspicions that this is due to a power supply failure i had earlier which screwed up my win XP profile royally and which therefore might create some troubles for the installation program when it wants to find the users folder (or it might be that the ini is created on the first run of Civ and it has managed to hang before creating the ini every time....). But since i dont really have time to reinstall XP atm, i would be extremely happy if someone could share the contents of the My Games folder with me. If you want to upload it to my ftp, i will try to get it up and running, or if you have an ftp of your own, i would be extremely thankful.

  2. Nadir

    Nadir Chieftain

    Oct 27, 2005
    Come on, cant someone please just post the civilizationIV.ini file? Judging by the links in the folder this seems to be the most important missing file.
  3. Repairman_Jack

    Repairman_Jack Chieftain

    Oct 27, 2005
    There isn't any .ini file in this game for some reason (I tried looking to fix my soundtrack problem). My game's working fine, though, so it's clearly not needed. ;)
  4. Nadir

    Nadir Chieftain

    Oct 27, 2005
    Ummm, ok... Why do they talk about CivilizationIV.ini in the readme then? And i've seen several people here mentioning changing the ini file. It is supposed to be placed in My Documents\My Games\<game folder> according to the readme. And there is a link in the game install folder pointing to a file called CivilizationIV.ini in the My Documents\My Games folder. The problem is that that link file is invalid on my computer due to the fact that the file it is pointing to does not exist.

    Ooops. It was called CivilizationIV.ini in the readme. Still missing though...
  5. Mazruk

    Mazruk Chieftain

    Oct 13, 2005
    Bristol, UK
    could it be hidden and you have explorer to not show hidden files?

    Alternatively, is explorer not showing the extensions (the .ini bit) ?
  6. Nadir

    Nadir Chieftain

    Oct 27, 2005
    Nope, i always have show hidden and system files on and show extensions for all files. Dont use explorer in any case ;)

    And even if they were just hidden, the search of the whole HD would still find it and the link file in the game install folder wouldnt be invalid. So it is missing allright. Irritating.

    Now please, cant someone just copy and paste it or something at least so that i can try to find out if this is really the problem?
  7. NARC

    NARC Chieftain

    Oct 27, 2005
    Most games will create the .ini file the first time the game is run. This is true for game slike Quake III, Unreal Tournament 2k4, and some others I'm sure.

    So it may not be missing, but you may not have been able to successfully run it, so it was not created.
  8. ThanatosXXX

    ThanatosXXX Chieftain

    Oct 27, 2005
    Nadir, there is indeed an INI file.

    Mine's in My Documents\My Games\Sid Meier's Civilization 4 and while I don't know how to post a file here I'll just cut'n'paste the contents. (Note, whether it actually does anything or not there's a blank line above [GAME])


    ; Map Script file name
    Map = Continents

    ; GameType options are singlePlayer/spLoad
    GameType = singlePlayer

    ; Pitboss Turn Time
    PitbossTurnTime = 0

    ; Max number of turns (0 for no turn limit)
    MaxTurns = 0

    ; Handicap for quick play
    QuickHandicap = HANDICAP_SETTLER






    ; Game Name
    GameName = JEFFINATOR

    ; Save Path - relative to working (Civ4) folder
    FileName = 0

    ; Account Username
    Nickname = JEFFINATOR

    ; Email Address
    Email = JEFFINATOR

    ; In-game Alias
    Alias = JEFFINATOR

    ; Move along
    CheatCode = 0


    ; Allow Mouse Scrolling in Windowed mode
    MouseScrolling = 0

    ; Enable Trilinear Filtering for the Minimap
    MinimapTrilinearFilter = 1

    ; Enable Tree Region Cutting
    CutTrees = 1

    ; Enable Quick Slide Show Transitions
    PopSlides = 0

    ; Random seed for map generation, or '0' for default
    MapRandSeed = 0

    ; Random seed for game sync, or '0' for default
    SyncRandSeed = 0

    ; Bandwidth options are modem or broadband
    Bandwidth = broadband

    ; QuickStart - SinglePlayer games only!
    QuickStart = 0

    ; Enable/disable background music
    PlayMusic = 1

    ; Allow Screenshots. May affect performance on some video cards
    AllowScreenShots = 1

    ; App Selects Specific IP to use for Multiplayer
    SelectIP = 0

    ; Specify a Mod folder (Mods\Mesopotamia), '0' for none
    Mod = 0

    ; Specify whether to play in fullscreen mode 0/1/ask
    FullScreen = 1

    ; Set max frame rate clamp (0 means none)
    SetMaxFrameRate = 0

    ; Set to 1 for dynamic animation paging
    DynamicAnimPaging = 1

    ; Set to 1 for no in-game movies
    NoMovies = 0

    ; Set to 1 for no python exception popups
    HidePythonExceptions = 1

    ; Specify the number of turns between autoSaves. 0 means no autosave.
    AutoSaveInterval = 4

    ; Enable Audio
    AudioEnable = 1

    ; English(0),French(1),German(2),Italian(3),Spanish(4) - Defaults to user-installed language
    Language = 0

    ; Determines which user profile is loaded on game start
    UserProfile = Default Profile

    ; Sync input to smooth interface (may run slower)
    SyncInput = 0

    ; Force numlock always on while playing
    ForceNumlock = 0


    ; Number of turns to autorun before exit (0 for no limit)
    AutorunTurnLimit = 0

    ; Set App on Auto-Run
    Autorun = 0

    ; Enable D3D9 Queries
    D3D9Query = 0

    ScreenHeight = 0

    ; Custom Screen Resolution, ex: 1200x1200 - Normal resolutions can be set in-game and will be used when both values are set to 0
    ScreenWidth = 0

    ; Establish connection to Python Debugger
    HAPDebugger = 0

    ; Show python debug msgs in IDE console
    ShowPythonDebugMsgs = 0

    ; NetComm Port
    Port = 2056

    ; Enable the logging system
    LoggingEnabled = 0

    ; Overwrite old network and message logs
    OverwriteLogs = 0

    ; Enable rand event logging
    RandLog = 0

    ; Enable message logging
    MessageLog = 0

    ; Break on memory allocation order #
    BreakOnAlloc = -1

Share This Page