1. Firaxis celebrates the "Asian American and Pacific Islander Heritage Month", and offers a give-away of a Civ6 anthology copy (5 in total)! For all the details, please check the thread here. .
    Dismiss Notice
  2. Old World has finally been released on GOG and Steam, besides also being available in the Epic store . Come to our Old World forum and discuss with us!
    Dismiss Notice

Multiplayer Crash issue

Discussion in 'Civ6 - Technical Support' started by Draahk, Jun 26, 2021.

  1. Draahk

    Draahk Chieftain

    Joined:
    Jun 26, 2021
    Messages:
    1
    Gender:
    Male
    Hi all, ive tried finding a fix for this but none seem to exist. So i post here in hopes someone got any idea on whats going on.

    When i play multiplayer with my two friends, my game crashes. It happends at random, and only ingame. Its like the game alt+f4's on me, no crash log or anything.

    my computer:
    i11700k
    RTX3070
    16Gb RAM
    m.2 hdd.

    Are there any known issues and fixes for this?

    What ive tried:
    Changed computer(got two, another which is almost as strong with i8770k, gtx960, 16Gb ram) and its the same thing there.
    Deleted the directories (cache, dumps, logs, moduserdata, packagedumps)
    turned down settings.
    re-installed the game multiple times.
    Running no mods, but with all expansions.

    im at a loss, anyone got any idea on how to fix this? its completely destroying the game for me
     
    Knightfall likes this.

Share This Page