Multiplayer save failing to load: MomentIllustrations and UpdateDatabase issue

Jan 2, 2021
Hi, i started a multiplayer game with my friend, after some minutes of gameplay he crashed and i've tried to reload the save so we could continue, but now the save (this, and other autosaves before) doesn't load

I grabbed the Database and Modding logs and the main issue seems to be this:

[3320168.611] [Gameplay] ERROR: no such table: MomentIllustrations
[3320168.611] [Gameplay]: In Query - insert into MomentIllustrations('MomentIllustrationType', 'MomentDataType', 'GameDataType', 'Texture') values (?, ?, ?, ?);
[3320168.611] [Gameplay]: In XMLSerializer while updating table MomentIllustrations from file Nubia_Expansion2.xml.

This happens with other expansions too, but the error is the same

In the end of the Database log, it also gives me many Invalid References, like this

[3320169.369] [Gameplay] ERROR: Invalid Reference on AgendaPreferredLeaders.AgendaType - "AGENDA_SYMPATHIZER" does not exist in RandomAgendas

[3320169.384] [Gameplay] ERROR: Invalid Reference on Types.Kind - "KIND_NAMED_RIVER" does not exist in Kinds

In the Modding log, it fails to load the XML of these mods too, for example:

[3320168.611] UpdateDatabase - Loading Data/Nubia_Expansion2.xml
[3320168.611] Warning: UpdateDatabase - Error Loading XML.

Here are the pastebins for the two logs

Here is the save file if someone wants to test (it failed on both pcs)
Jan 2, 2021
I've deleted the XML files and redownloaded them and the issue still occurs

I've also tried to use this method to fix it (by adding the values using Notepad++) and it also doesn't seems to work:

Maybe it's because the game detects an issue with the file? and redownloads it? idk, but in the Moddings log for example it shows me this

[3320121.810] File timestamps do not match. Will reload the mod.
[3320121.813] Loading Mod - ../../../DLC/Aztec_Montezuma/Aztec_Montezuma.modinfo
[3320121.814] Checking for additional mod fragments...
[3320121.859] Finished Discovery.
[3320121.860] Discovery Summary:
[3320121.860] Deleted 1 mods.
[3320121.860] Discovered 1 mods.
[3320121.860] New/Reloaded Mods:
[3320121.886] 02A8BDDE-67EA-4D38-9540-26E685E3156E (LOC_AZTEC_MONTEZUMA_MOD_TITLE)
[3320121.910] Discovering Mods took - 339ms.
[3320121.919] Verifying enabled mods can coexist.
[3320121.953] Bootstrapping game content
[3320121.953] Loading Vanilla DLL.
Top Bottom