problem with new civ


Apr 14, 2002
Trois-Rivieres, Quebec
This is the first time I've tried anything like this and so I can't find what I've done wrong.

I used Civ3CopyTool to add an extra civ to a bic file (not civ3mod). I copied the Persians and loaded the scenario in Civ3Edit. In the civilizations rules section, it had all the normal civs plus a second version of the Persians, which I renamed the Canadians and modified accordingly.

Then I used the copier to make a copy of the settler unit and modified this copy with Civ3Edit. I renamed it the Coureur des Bois and gave it 2 movement points and the ability to build fortresses. I also went through the list of units and added Canada to the countries which can build each specific unit, except of course for the civ-specific unit. I did say the coureur des bois was Canada only. I did not add Canada to the list of those that can build the settler since they have an improved version.

I then used the civilopedia editor to create entries for Canada and the coureur des bois.

When I launched the game and attempted to load the scenario, I got a message that said Civ 3 would shut down because it had performed an illegal action. I had to restart the PC to get the game to work again. I again tried loading the scenario and got to the civ selection screen. There was an additional button for an extra civ, but nothing written beside it. When I clicked the button, the game froze up.

I restored the original civilopedia.txt and changed the entries for my civ and unit to the entries for the British and the Settler to make sure it wasn't my entries crashing the game. Everytime I've tried loading the scenario since then the game has given me the same error as the first time.

Does anyone know what is causing this?

I think maybe it's the fact that Canada can't build Settlers which screws the game because then they are supposed to start with a settler but can't, however the game doesn't know to put in a coureur des bois instead of a settler. I was thinking of changing the coureur des bois to a faster or defensive-ish explorer who can build colonies and forts anyway, which I think would be more appropriate.


Well I just modified the coureur des bois to make it an explorer like I said earlier and I made the settler creatable by Canada but the game still crashes... I guess it must be something wrong with the actual game copy
It probably isn't your game copy. Check the following:

1) Did you add entries for your new civ in the PediaIcons.txt file. This tells the computer where to look for leaderheads for each civ, as well as other things, like citizen moods, etc.

2) You may also have to add a new entry for Diplomacy in the Diplomacy.txt file...not sure about this because I've never add a new civ before. There's a tutorial available for adding diplomacy material somewhere on this site.

3) In order to have your civ's name appear on the start-up screen (next to the button), you'll probably have to add an entry for it in labels.txt (or is it script.txt? should probably check them both out).

4) Your new unit will also need an entry for it in the PediaIcons.txt file to find the correct unitlarge.pcx and unitsmall.pcx pictures (you can just direct it to look for the settler pictures).

Hope this helps you out.
Do I need to add the extra info to pediaicons.txt even if I use the explorer and english entries instead of custom entries?
If the Civilopedia Entry box says RACE_ENGLISH for your new civ, then I don't think you'll need to add any entries to PediaIcons because it should just use the some ones as for the English. However, you will probably still need to add to Diplomacy, because (if I remember correctly) that is based on the number order of the civs, rather than their Civilopedia entries. However, you could probably just copy all of the diplomacy text for the English and paste it for the Canadians (but you should probably read the diplomacy.txt tutorial before you do this, just to be sure).

The same goes for the unit: if the Civilopedia entry says PRTO_Explorer, then it should just use the same unitlarge and unitsmall pics that the Explorer uses.
I'm not sure how the copier works, but your new unit may not have artwork. Check the art/units folder in your Civ3 folder. If there's a folder for your Coureur des Bois, spelled correctly, then that's not the problem.

If not...

Right click on the Settler folder, select copy. Right click on a blank space, select paste. Rename the Copy of Settler folder to Coureur des Bois. Go into the folder, rename Settler.INI to Coureur des Bois.INI.

If they're building fortresses, well, you've got an overpowered unit (a two-move settler is overpowering anyway), but that's not your problem. You will need to copy over some information from the Worker folder to give it artwork for fortress building. I don't exactly remember which, but I'm sure someone else does.
Not need copy whole folder. Just make new folder 'Coureur des Bois'. Copy Settler.INI from Settler folder to the new and rename to 'Coureur des Bois.INI'. Edit this ini with adding path ..\Settler\
et cetera
Thanks you guys.

I did what you said and took a look at Montezuma's instructions in the post that Ed O'War's link leads to. Turns out there was a lot of stuff I didn't know I was supposed to change, but now I've done it and the scenario works.

I made the coureur des bois an improved explorer rather than a settler. The unit works just fine. I also made a bunch of pics and flics for Trudeau as Canadian leader. I edited diplomacy.txt and civilopedia.txt with new entries for Canada and their unit. Now I can get into the scenario and play as Canada or anyone else and everything works just fine, except for one thing:

Some of the Trudeau pictures are not working. I can see the proper movie of him when I select the Canadian civ at the start of the game or when I use another civ to talk to the AI Trudeau. However, I can't see the civilopedia pics of trudeau, nor can I access the foreign advisor screen when I either am Trudeau or have already contacted him, in other words, when his pic would normally show up. Basically, I can see the movie, but none of the pictures...

Civilopedia: I made all the pics in the leaderheads folder, mimicking Lincoln's pics. I made each pic the same size as its Abe counterpart and used the same naming system, replacing AB by TR. For example, AB_CULT.pcx becomes TR_CULT.pcx I also made a trudeau version of the pic in the advisors folder, naming this one TR_all.pcx. For the coureur des bois, I linked the .ini file in the unit's folder to the explorer images. Then I added civilopedia entries for the civ and the unit. I can tell these work fine because I can read them when I'm in the game. Then I went and edited PediaIcons.txt and added entries for canada below each entry for the English, referencing each of my custom pics. I also referenced my coureur des bois to explorer pics. Now when I go to the civilopedia in the game, the coureur des bois pics work just fine. However, when I click on "Tribes" I see all the small pics of the leaders, except Trudeau. Instead, I get a black-and-white, very bad quality pic of Hammurabi. If I move my cursor over the pic or over the word Canada, this becomes a black-and-white, equally low quality pic of Caesar... If I actually click, all I get is a blank black image instead of a Trudeau pic in the upper righthand corner.

Foreign Advisor: When I either press F4 or click on the Foreign Advisor from another advisor's window, the game jams and I must ctrl-alt-delete it. It occasionally forces me to restart my PC.

I've quadruple-checked all my filenames and all my referencing in civilopedia.txt and pediaicons.txt to make sure it was all spelled correctly, and it is.

I thought I had found the problem about an hour ago when I realized all the actual leaderpics from civ were 256-colour, while mine were a sometimes 24-bit, sometimes monochrome, etc. I converted them all to 256, convinced it would solve my problem. To my dismay, the same things still happen....

Do you know why it would be doing this?
Top Bottom